summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-mobilephone/vmoconv')
-rw-r--r--app-mobilephone/vmoconv/files/vmoconv-1.0-flags.patch14
-rw-r--r--app-mobilephone/vmoconv/files/vmoconv-1.0-glibc28.patch12
-rw-r--r--app-mobilephone/vmoconv/vmoconv-1.0-r1.ebuild20
3 files changed, 27 insertions, 19 deletions
diff --git a/app-mobilephone/vmoconv/files/vmoconv-1.0-flags.patch b/app-mobilephone/vmoconv/files/vmoconv-1.0-flags.patch
index 031b6eefaaca..c0d145257858 100644
--- a/app-mobilephone/vmoconv/files/vmoconv-1.0-flags.patch
+++ b/app-mobilephone/vmoconv/files/vmoconv-1.0-flags.patch
@@ -1,6 +1,14 @@
-diff -Nru vmoconv-1.0.orig/configure.in vmoconv-1.0/configure.in
---- vmoconv-1.0.orig/configure.in 2004-09-26 15:17:48.000000000 +0000
-+++ vmoconv-1.0/configure.in 2009-03-03 21:32:40.000000000 +0000
+--- a/configure.in
++++ b/configure.in
+@@ -2,7 +2,7 @@
+ # try CFLAGS="$CFLAGS -g -Wall -Wmissing-declarations -Wmissing-prototypes -Werror"
+ AC_INIT(vmoconv, 1.0, zany@triq.net)
+ AM_INIT_AUTOMAKE(vmoconv, 1.0)
+-AM_CONFIG_HEADER(config.h)
++AC_CONFIG_HEADERS(config.h)
+
+ dnl AM_MAINTAINER_MODE
+
@@ -26,10 +26,10 @@
[printf(__func__)],,
[AC_DEFINE(__func__, "", [non-C99 fake support for __func__])])
diff --git a/app-mobilephone/vmoconv/files/vmoconv-1.0-glibc28.patch b/app-mobilephone/vmoconv/files/vmoconv-1.0-glibc28.patch
index ec957b40c5cd..02c000412fbf 100644
--- a/app-mobilephone/vmoconv/files/vmoconv-1.0-glibc28.patch
+++ b/app-mobilephone/vmoconv/files/vmoconv-1.0-glibc28.patch
@@ -1,6 +1,5 @@
-diff -Naur vmoconv-1.0.orig/src/gsm2vmo.c vmoconv-1.0/src/gsm2vmo.c
---- vmoconv-1.0.orig/src/gsm2vmo.c 2008-06-15 12:57:07.000000000 -0400
-+++ vmoconv-1.0/src/gsm2vmo.c 2008-06-15 12:57:36.000000000 -0400
+--- a/src/gsm2vmo.c
++++ b/src/gsm2vmo.c
@@ -27,7 +27,7 @@
* 12 bit header and 260 bits standard GSM frame, as described
* in GSM 06.10 and GSM 06.12. The header is 0x2010 always.
@@ -10,11 +9,10 @@ diff -Naur vmoconv-1.0.orig/src/gsm2vmo.c vmoconv-1.0/src/gsm2vmo.c
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
-diff -Naur vmoconv-1.0.orig/src/vmo2gsm.c vmoconv-1.0/src/vmo2gsm.c
---- vmoconv-1.0.orig/src/vmo2gsm.c 2008-06-15 12:57:07.000000000 -0400
-+++ vmoconv-1.0/src/vmo2gsm.c 2008-06-15 12:57:36.000000000 -0400
+--- a/src/vmo2gsm.c
++++ b/src/vmo2gsm.c
@@ -27,7 +27,7 @@
- * 12 bit header and 260 bits standard GSM frame, as described
+ * 12 bit header and 260 bits standart GSM frame, as described
* in GSM 06.10 and GSM 06.12. The header is 0x2010 always.
*/
-
diff --git a/app-mobilephone/vmoconv/vmoconv-1.0-r1.ebuild b/app-mobilephone/vmoconv/vmoconv-1.0-r1.ebuild
index 6a145ab58049..0e19246d04ba 100644
--- a/app-mobilephone/vmoconv/vmoconv-1.0-r1.ebuild
+++ b/app-mobilephone/vmoconv/vmoconv-1.0-r1.ebuild
@@ -1,31 +1,33 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=8
-inherit epatch autotools
+inherit autotools
DESCRIPTION="A tool that converts Siemens phones VMO and VMI audio files to gsm and wav"
HOMEPAGE="http://triq.net/obex/"
SRC_URI="http://triq.net/obexftp/${P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc x86"
-IUSE=""
DEPEND="media-sound/gsm"
RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${P}-glibc28.patch
+ "${FILESDIR}"/${P}-flags.patch
+ "${FILESDIR}"/${P}-external-libgsm.patch
+)
+
src_prepare() {
- epatch "${FILESDIR}/${P}-glibc28.patch"
- epatch "${FILESDIR}/${P}-flags.patch"
- epatch "${FILESDIR}/${P}-external-libgsm.patch"
- sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' configure.in || die
+ default
eautoreconf
}
src_install() {
dobin src/vmo2gsm src/gsm2vmo src/vmo2wav
- dodoc AUTHORS ChangeLog NEWS README THANKS
+ einstalldocs
}