summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-mobilephone/wammu/wammu-0.44.ebuild')
-rw-r--r--app-mobilephone/wammu/wammu-0.44.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-mobilephone/wammu/wammu-0.44.ebuild b/app-mobilephone/wammu/wammu-0.44.ebuild
new file mode 100644
index 000000000000..9abeda111418
--- /dev/null
+++ b/app-mobilephone/wammu/wammu-0.44.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Front-end for gammu to access mobile phones easily"
+HOMEPAGE="https://www.wammu.eu/"
+SRC_URI="http://dl.cihar.com/wammu/v0/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bluetooth gnome"
+
+RDEPEND="
+ >=app-mobilephone/gammu-1.36
+ dev-python/python-gammu
+ >=dev-python/wxpython-2.8:*[${PYTHON_USEDEP}]
+ bluetooth? (
+ dev-python/pybluez[${PYTHON_USEDEP}]
+ gnome? ( net-wireless/gnome-bluetooth )
+ )
+"
+DEPEND="${RDEPEND}"
+
+# Required to source locale content out of the box
+DISTUTILS_IN_SOURCE_BUILD=1
+
+# SKIPWXCHECK: else 'import wx' results in
+# Xlib: connection to ":0.0" refused by server
+SKIPWXCHECK=yes