summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/homebank/homebank-5.7.3.ebuild')
-rw-r--r--app-office/homebank/homebank-5.7.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-office/homebank/homebank-5.7.3.ebuild b/app-office/homebank/homebank-5.7.3.ebuild
new file mode 100644
index 000000000000..fc261abdd2a8
--- /dev/null
+++ b/app-office/homebank/homebank-5.7.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit xdg
+
+DESCRIPTION="Free, easy, personal accounting for everyone"
+HOMEPAGE="https://www.gethomebank.org/"
+SRC_URI="https://www.gethomebank.org/public/sources/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+ofx"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+RDEPEND=">=dev-libs/glib-2.39:2
+ net-libs/libsoup:3.0
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/pango
+ ofx? ( >=dev-libs/libofx-0.8.3:= )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND=">=dev-lang/perl-5.8.1
+ dev-perl/XML-Parser
+ >=dev-util/intltool-0.40.5
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog README )
+
+src_configure() {
+ econf $(use_with ofx)
+}