summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/kraft/kraft-0.80.ebuild')
-rw-r--r--app-office/kraft/kraft-0.80.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-office/kraft/kraft-0.80.ebuild b/app-office/kraft/kraft-0.80.ebuild
new file mode 100644
index 000000000000..ea0cd15a44f1
--- /dev/null
+++ b/app-office/kraft/kraft-0.80.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Software to manage quotes and invoices in small enterprises"
+HOMEPAGE="http://www.volle-kraft-voraus.de/"
+SRC_URI="https://github.com/dragotin/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="pim"
+
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep kcontacts)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtsql)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ dev-cpp/ctemplate
+ pim? (
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-contacts)
+ )
+"
+RDEPEND="${DEPEND}
+ !app-office/kraft:4
+"
+
+DOCS=( AUTHORS Changes.txt README.md Releasenotes.txt TODO )
+
+PATCHES=( "${FILESDIR}/${P}-qt-5.11.patch" )
+
+S="${WORKDIR}/${PN}-${PV/_/}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package pim KF5Akonadi)
+ $(cmake-utils_use_find_package pim KF5AkonadiContact)
+ )
+
+ kde5_src_configure
+}