summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/kraft')
-rw-r--r--app-office/kraft/Manifest1
-rw-r--r--app-office/kraft/files/kraft-0.80_pre20171115-deps.patch62
-rw-r--r--app-office/kraft/kraft-0.80_pre20171115.ebuild48
-rw-r--r--app-office/kraft/metadata.xml5
4 files changed, 115 insertions, 1 deletions
diff --git a/app-office/kraft/Manifest b/app-office/kraft/Manifest
index 878334422936..854ce2518dcd 100644
--- a/app-office/kraft/Manifest
+++ b/app-office/kraft/Manifest
@@ -1 +1,2 @@
DIST kraft-0.59.tar.xz 560116 SHA256 e05ff0b78a073bafffa5c0e41fe458461216b66fd57fc9432a1064a7be2b2034 SHA512 53576855e3a4ac054818cc3fcb5d123222c0a5839ba621ea7c1f390f1e3180b5c87b00daa09a57fbea64cbd1dc857c4cb7645c5f539635811ef236c76483dc36 WHIRLPOOL d442c33ecbee4f0b3d8f33b358a5f7fab9f9c99d5e70019ca9d5910a3b717530008b6b09c3573132a27681f9e554f83f1798bc6b5a71d71fd10c81884692dd6e
+DIST kraft-0.80_pre20171115.tar.gz 572784 SHA256 b5ded884a9377fe88013aef9a230580e9f6fb9873764abe226736843489c1eae SHA512 7c9fa4b8c17809c36f4f6d94f4d6b900f91083c86b332d7680db1ad721904823b25cab5b8393913220dea9b16937bc90ac403af8f57fc6f963d59af41e1f51c3 WHIRLPOOL 2a62d59153a43bd473ad565baf09775b981047b6d998a2fd6f4e32ae4d57a56bb577b375e2896e67b23b2abef80f453e1cd44dc39b5dbe7c3b74a1236d1eeb87
diff --git a/app-office/kraft/files/kraft-0.80_pre20171115-deps.patch b/app-office/kraft/files/kraft-0.80_pre20171115-deps.patch
new file mode 100644
index 000000000000..cebf558fd355
--- /dev/null
+++ b/app-office/kraft/files/kraft-0.80_pre20171115-deps.patch
@@ -0,0 +1,62 @@
+From 63248f8004e7e0b05fe1716f6ff432b16b382e8f Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Thu, 16 Nov 2017 22:14:05 +0100
+Subject: [PATCH] Sort deps, add implicit, and split PIM from real KF5 libs
+
+Add descriptions to PIM dependencies.
+---
+ CMakeLists.txt | 33 ++++++++++++++++++++++++++-------
+ 1 file changed, 26 insertions(+), 7 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 739daac..9f95ecf 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -25,21 +25,40 @@ remove_definitions(-DQT_NO_CAST_FROM_ASCII)
+
+ find_package(Qt5 CONFIG REQUIRED
+ Core
+- Network
+- Widgets
++ Gui
+ Sql
++ Widgets
++ Xml
+ )
+
+ find_package(KF5 REQUIRED COMPONENTS
+- Contacts
++ Config
++ ConfigWidgets
++ CoreAddons
+ I18n
++ WidgetsAddons
+ XmlGui
+- OPTIONAL_COMPONENTS
+- Akonadi
+- AkonadiContact
+ )
+
+-if(KF5Akonadi_FOUND)
++find_package(KF5Contacts REQUIRED)
++
++find_package(KF5Akonadi)
++set_package_properties(KF5Akonadi PROPERTIES
++ DESCRIPTION "Library for general Access to Akonadi"
++ URL "https://www.kde.org/"
++ PURPOSE "Optionally used for addressbook integration"
++ TYPE OPTIONAL
++)
++
++find_package(KF5AkonadiContact)
++set_package_properties(KF5AkonadiContact PROPERTIES
++ DESCRIPTION "Library for Accessing Contacts stored in Akonadi"
++ URL "https://www.kde.org/"
++ PURPOSE "Optionally used for addressbook integration"
++ TYPE OPTIONAL
++)
++
++if(KF5Akonadi_FOUND AND KF5AkonadiContact_FOUND)
+ add_definitions(-DHAVE_AKONADI)
+ endif()
+
diff --git a/app-office/kraft/kraft-0.80_pre20171115.ebuild b/app-office/kraft/kraft-0.80_pre20171115.ebuild
new file mode 100644
index 000000000000..cc3b1e38dba5
--- /dev/null
+++ b/app-office/kraft/kraft-0.80_pre20171115.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+COMMIT=6618f5203f80a52e673cfad1a12dcee9154e2831
+KDE_HANDBOOK="forceoptional"
+inherit kde5 vcs-snapshot
+
+DESCRIPTION="Software to manage quotes and invoices in small enterprises"
+HOMEPAGE="http://www.volle-kraft-voraus.de/"
+SRC_URI="https://github.com/dragotin/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="pim"
+
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep kcontacts)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtsql)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ dev-cpp/ctemplate
+ pim? (
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-contacts)
+ )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS Changes.txt README Releasenotes.txt TODO )
+
+PATCHES=( "${FILESDIR}/${P}-deps.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package pim KF5Akonadi)
+ $(cmake-utils_use_find_package pim KF5AkonadiContact)
+ )
+
+ kde5_src_configure
+}
diff --git a/app-office/kraft/metadata.xml b/app-office/kraft/metadata.xml
index 38bfeaed7bbc..5884c2d79636 100644
--- a/app-office/kraft/metadata.xml
+++ b/app-office/kraft/metadata.xml
@@ -6,6 +6,9 @@
<name>Gentoo KDE Project</name>
</maintainer>
<upstream>
- <remote-id type="sourceforge">kraft</remote-id>
+ <remote-id type="github">dragotin/kraft</remote-id>
</upstream>
+ <use>
+ <flag name="pim">Enable support for KDE PIM resources integration</flag>
+ </use>
</pkgmetadata>