summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/libreoffice/libreoffice-6.2.9999.ebuild')
-rw-r--r--app-office/libreoffice/libreoffice-6.2.9999.ebuild28
1 files changed, 2 insertions, 26 deletions
diff --git a/app-office/libreoffice/libreoffice-6.2.9999.ebuild b/app-office/libreoffice/libreoffice-6.2.9999.ebuild
index caf354cdab3b..79a08e6a2d58 100644
--- a/app-office/libreoffice/libreoffice-6.2.9999.ebuild
+++ b/app-office/libreoffice/libreoffice-6.2.9999.ebuild
@@ -428,8 +428,8 @@ src_configure() {
--with-x
--without-fonts
--without-myspell-dicts
- --without-help
- --with-helppack-integration
+ --with-help="html"
+ --without-helppack-integration
--with-system-gpgmepp
--without-system-sane
$(use_enable bluetooth sdremote-bluetooth)
@@ -506,24 +506,6 @@ src_compile() {
addpredict /dev/ati
addpredict /dev/nvidiactl
- # hack for offlinehelp, this needs fixing upstream at some point
- # it is broken because we send --without-help
- # https://bugs.freedesktop.org/show_bug.cgi?id=46506
- (
- grep "^export" "${S}/config_host.mk" > "${T}/config_host.mk" || die
- source "${T}/config_host.mk" 2&> /dev/null
-
- local path="${WORKDIR}/helpcontent2/source/auxiliary/"
- mkdir -p "${path}" || die
-
- echo "perl \"${S}/helpcontent2/helpers/create_ilst.pl\" -dir=helpcontent2/source/media/helpimg > \"${path}/helpimg.ilst\""
- perl "${S}/helpcontent2/helpers/create_ilst.pl" \
- -dir=helpcontent2/source/media/helpimg \
- > "${path}/helpimg.ilst"
- [[ -s "${path}/helpimg.ilst" ]] || \
- ewarn "The help images list is empty, something is fishy, report a bug."
- )
-
local target
use test && target="build" || target="build-nocheck"
@@ -558,12 +540,6 @@ src_install() {
echo "CONFIG_PROTECT=/usr/$(get_libdir)/${PN}/program/sofficerc" > "${ED}"/etc/env.d/99${PN} || die
fi
- # Hack for offlinehelp, this needs fixing upstream at some point.
- # It is broken because we send --without-help
- # https://bugs.freedesktop.org/show_bug.cgi?id=46506
- insinto /usr/$(get_libdir)/libreoffice/help
- doins xmlhelp/util/*.xsl
-
pax-mark -m "${ED}"/usr/$(get_libdir)/libreoffice/program/soffice.bin
pax-mark -m "${ED}"/usr/$(get_libdir)/libreoffice/program/unopkg.bin
}