summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/pybliographer')
-rw-r--r--app-office/pybliographer/Manifest1
-rw-r--r--app-office/pybliographer/metadata.xml17
-rw-r--r--app-office/pybliographer/pybliographer-1.2.15-r1.ebuild67
3 files changed, 85 insertions, 0 deletions
diff --git a/app-office/pybliographer/Manifest b/app-office/pybliographer/Manifest
new file mode 100644
index 000000000000..8ac8c3279fd1
--- /dev/null
+++ b/app-office/pybliographer/Manifest
@@ -0,0 +1 @@
+DIST pybliographer-1.2.15.tar.gz 1859977 SHA256 dde66734e3839de92fe068c7804c1e580a049dfe91316df47ec0552236de6ce4 SHA512 f4b3478f60f042ebc7538f044a8c4014fda5202576e3f894b31c79430400e834c59f859f895efa187a89016f4e2625ee6be20751f31843e179fbdfb54ba65330 WHIRLPOOL 0bba23bce6deb39ec5efaac5c9e966c8e70853096e37fedfdb0dbcf41030247df715b55233977a0261c2a21c6e8cfb35b4cf6551ab2908baa889e4502ace0e92
diff --git a/app-office/pybliographer/metadata.xml b/app-office/pybliographer/metadata.xml
new file mode 100644
index 000000000000..15047be8bef5
--- /dev/null
+++ b/app-office/pybliographer/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>tex</herd>
+ <longdescription lang="en">
+ Pybliographer is a tool for managing bibliographic databases, with
+ the following features:
+ * a user-friendly Gnome interface for editing, searching, inserting
+ your citations in LyX, Kile and OpenOffice.org, searching external
+ databases like PubMed, Web of Science, Citeseer, and more.
+ * powerful APIs to integrate these features into your own custom
+ application, with your own specific database schema.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">pybliographer</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-office/pybliographer/pybliographer-1.2.15-r1.ebuild b/app-office/pybliographer/pybliographer-1.2.15-r1.ebuild
new file mode 100644
index 000000000000..315dfc062fdf
--- /dev/null
+++ b/app-office/pybliographer/pybliographer-1.2.15-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+GCONF_DEBUG="no"
+
+inherit autotools gnome2 python-single-r1
+
+DESCRIPTION="Pybliographer is a tool for working with bibliographic databases"
+HOMEPAGE="http://pybliographer.org/"
+SRC_URI="mirror://sourceforge/pybliographer/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=app-text/recode-3.6-r1
+ app-text/scrollkeeper
+ dev-libs/glib:2
+ dev-python/gconf-python:2[${PYTHON_USEDEP}]
+ dev-python/gnome-vfs-python:2[${PYTHON_USEDEP}]
+ dev-python/libgnome-python:2[${PYTHON_USEDEP}]
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ >=dev-python/python-bibtex-1.2.5[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ app-text/gnome-doc-utils
+"
+
+src_prepare() {
+ # Workaround for bug 487204.
+ sed -i \
+ -e 's:\$(srcdir)/::g' \
+ tests/Makefile.am || die "sed failed"
+
+ # Install Python modules into site-packages directories.
+ find -name Makefile.am | xargs sed -i \
+ -e "/^pybdir[[:space:]]*=[[:space:]]*/s:\$(datadir):$(python_get_sitedir):" || die "sed failed"
+ sed -i \
+ -e "s:\${datadir}/@PACKAGE@:$(python_get_sitedir)/@PACKAGE@:" \
+ etc/installer.in || die "sed failed"
+ sed -i \
+ -e "s:gladedir = \$(datadir):gladedir = $(python_get_sitedir):" \
+ Pyblio/GnomeUI/glade/Makefile.am || die "sed failed"
+
+ # Fix shebang manually as otherwise python_fix_shebang gets confused
+ sed -i -e 's: @python_path@:/usr/bin/python2:' pybliographer.py || die
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure --disable-depchecks
+}
+
+src_install() {
+ gnome2_src_install
+ python_fix_shebang "${D}"
+}