summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/scribus')
-rw-r--r--app-office/scribus/files/scribus-1.5.6.1-poppler-21.03.0-1.patch53
-rw-r--r--app-office/scribus/files/scribus-1.5.6.1-poppler-21.03.0-2.patch27
-rw-r--r--app-office/scribus/scribus-1.5.6.1.ebuild3
3 files changed, 82 insertions, 1 deletions
diff --git a/app-office/scribus/files/scribus-1.5.6.1-poppler-21.03.0-1.patch b/app-office/scribus/files/scribus-1.5.6.1-poppler-21.03.0-1.patch
new file mode 100644
index 000000000000..18c1edcaaa99
--- /dev/null
+++ b/app-office/scribus/files/scribus-1.5.6.1-poppler-21.03.0-1.patch
@@ -0,0 +1,53 @@
+From 7ce0ac16fd42d61ef9082b27822c7d9d79c7fef7 Mon Sep 17 00:00:00 2001
+From: Jean Ghali <jghali@libertysurf.fr>
+Date: Mon, 1 Mar 2021 21:52:54 +0000
+Subject: [PATCH] Attempt to fix build of pdf import plugin with poppler
+ 21.03.0
+
+git-svn-id: svn://scribus.net/trunk/Scribus@24537 11d20701-8431-0410-a711-e3c959e3b870
+---
+ scribus/plugins/import/pdf/slaoutput.cpp | 12 +++++++++++-
+ scribus/plugins/import/pdf/slaoutput.h | 4 ++++
+ 2 files changed, 15 insertions(+), 1 deletion(-)
+
+diff --git a/scribus/plugins/import/pdf/slaoutput.cpp b/scribus/plugins/import/pdf/slaoutput.cpp
+index 7cbc73e8d4..d1b37a0c21 100644
+--- a/scribus/plugins/import/pdf/slaoutput.cpp
++++ b/scribus/plugins/import/pdf/slaoutput.cpp
+@@ -2292,9 +2292,19 @@ GBool SlaOutputDev::patchMeshShadedFill(GfxState *state, GfxPatchMeshShading *sh
+ return gTrue;
+ }
+
+-GBool SlaOutputDev::tilingPatternFill(GfxState *state, Gfx * /*gfx*/, Catalog *cat, Object *str, POPPLER_CONST_070 double *pmat, int paintType, int tilingType, Dict *resDict, POPPLER_CONST_070 double *mat, POPPLER_CONST_070 double *bbox, int x0, int y0, int x1, int y1, double xStep, double yStep)
++#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(21, 3, 0)
++bool SlaOutputDev::tilingPatternFill(GfxState *state, Gfx * /*gfx*/, Catalog *cat, GfxTilingPattern *tPat, const double *mat, int x0, int y0, int x1, int y1, double xStep, double yStep)
++#else
++GBool SlaOutputDev::tilingPatternFill(GfxState *state, Gfx * /*gfx*/, Catalog *cat, Object *str, POPPLER_CONST_070 double *pmat, int /*paintType*/, int /*tilingType*/, Dict *resDict, POPPLER_CONST_070 double *mat, POPPLER_CONST_070 double *bbox, int x0, int y0, int x1, int y1, double xStep, double yStep)
++#endif
+ {
+ // qDebug() << "SlaOutputDev::tilingPatternFill";
++#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(21, 3, 0)
++ const double *bbox = tPat->getBBox();
++ const double *pmat = tPat->getMatrix();
++ Dict *resDict = tPat->getResDict();
++#endif
++
+ PDFRectangle box;
+ Gfx *gfx;
+ QString id;
+diff --git a/scribus/plugins/import/pdf/slaoutput.h b/scribus/plugins/import/pdf/slaoutput.h
+index 5149f19e31..66c34203ae 100644
+--- a/scribus/plugins/import/pdf/slaoutput.h
++++ b/scribus/plugins/import/pdf/slaoutput.h
+@@ -197,7 +197,11 @@ class SlaOutputDev : public OutputDev
+ void stroke(GfxState *state) override;
+ void fill(GfxState *state) override;
+ void eoFill(GfxState *state) override;
++#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(21, 3, 0)
++ bool tilingPatternFill(GfxState *state, Gfx *gfx, Catalog *cat, GfxTilingPattern *tPat, const double *mat, int x0, int y0, int x1, int y1, double xStep, double yStep) override;
++#else
+ GBool tilingPatternFill(GfxState *state, Gfx *gfx, Catalog *cat, Object *str, POPPLER_CONST_070 double *pmat, int paintType, int tilingType, Dict *resDict, POPPLER_CONST_070 double *mat, POPPLER_CONST_070 double *bbox, int x0, int y0, int x1, int y1, double xStep, double yStep) override;
++#endif
+ GBool functionShadedFill(GfxState * /*state*/, GfxFunctionShading * /*shading*/) override { qDebug() << "Function Shaded Fill"; return gFalse; }
+ GBool axialShadedFill(GfxState *state, GfxAxialShading *shading, double tMin, double tMax) override;
+ GBool axialShadedSupportExtend(GfxState *state, GfxAxialShading *shading) override { return (shading->getExtend0() == shading->getExtend1()); }
diff --git a/app-office/scribus/files/scribus-1.5.6.1-poppler-21.03.0-2.patch b/app-office/scribus/files/scribus-1.5.6.1-poppler-21.03.0-2.patch
new file mode 100644
index 000000000000..bff1c08b39ad
--- /dev/null
+++ b/app-office/scribus/files/scribus-1.5.6.1-poppler-21.03.0-2.patch
@@ -0,0 +1,27 @@
+From 6b9ff916959bcb941866f0bd86da639a421337f8 Mon Sep 17 00:00:00 2001
+From: Jean Ghali <jghali@libertysurf.fr>
+Date: Mon, 1 Mar 2021 22:00:02 +0000
+Subject: [PATCH] Attempt to fix build of pdf import plugin with poppler
+ 21.03.0
+
+git-svn-id: svn://scribus.net/trunk/Scribus@24538 11d20701-8431-0410-a711-e3c959e3b870
+---
+ scribus/plugins/import/pdf/slaoutput.cpp | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/scribus/plugins/import/pdf/slaoutput.cpp b/scribus/plugins/import/pdf/slaoutput.cpp
+index d1b37a0c21..de0a4145ef 100644
+--- a/scribus/plugins/import/pdf/slaoutput.cpp
++++ b/scribus/plugins/import/pdf/slaoutput.cpp
+@@ -2336,7 +2336,11 @@ GBool SlaOutputDev::tilingPatternFill(GfxState *state, Gfx * /*gfx*/, Catalog *c
+ // Unset the clip path as it is unrelated to the pattern's coordinate space.
+ QPainterPath savedClip = m_currentClipPath;
+ m_currentClipPath = QPainterPath();
++#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(21, 3, 0)
++ gfx->display(tPat->getContentStream());
++#else
+ gfx->display(str);
++#endif
+ m_currentClipPath = savedClip;
+ inPattern--;
+ gElements = m_groupStack.pop();
diff --git a/app-office/scribus/scribus-1.5.6.1.ebuild b/app-office/scribus/scribus-1.5.6.1.ebuild
index cd06c4f588f9..5d0d78d897af 100644
--- a/app-office/scribus/scribus-1.5.6.1.ebuild
+++ b/app-office/scribus/scribus-1.5.6.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -72,6 +72,7 @@ RDEPEND="${DEPEND}
"
PATCHES=(
+ "${FILESDIR}"/${P}-poppler-21.03.0-{1,2}.patch
# non(?)-upstreamable
"${FILESDIR}"/${PN}-1.5.3-fpic.patch
"${FILESDIR}"/${PN}-1.5.6-docdir.patch