summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office')
-rw-r--r--app-office/kraft/Manifest1
-rw-r--r--app-office/kraft/files/kraft-0.95-i18n-warning.patch35
-rw-r--r--app-office/kraft/kraft-0.95.ebuild47
3 files changed, 83 insertions, 0 deletions
diff --git a/app-office/kraft/Manifest b/app-office/kraft/Manifest
index 4ef693153324..bb0f44b04f24 100644
--- a/app-office/kraft/Manifest
+++ b/app-office/kraft/Manifest
@@ -1 +1,2 @@
DIST kraft-0.90.tar.gz 705767 BLAKE2B 63f048be32e794e3c13d59ebbac90558e661eabe8b08270ea684adc338e2ae45b59cfbb3a746d1248ff8c0026308209f2821cac7c2feaf67af04903125be34c7 SHA512 1ca87a828e74b508b229787459f32e8ab5ad0ca4bf2630e236d65beaaa7503dc61af42d3b13106aeb6e43fcf3c419133958c5492a2c25c7233c9ac0205b3800c
+DIST kraft-0.95.tar.gz 877790 BLAKE2B 4099845816191c5760f81a5512dc5d5afab1a76eb79c5d3fdead58d7a25342c4f461a6bf4d65313837d6bce32e80c1c8348f674b62358bb08cfdfd3ecf845bad SHA512 8070827a491b2a923b4608752ee2202377aeb2c472a3ee81feaad3b853d13bafe9f9c70719e1dfffeceb1492df80608327a56541453456be87a97bb3d5457f42
diff --git a/app-office/kraft/files/kraft-0.95-i18n-warning.patch b/app-office/kraft/files/kraft-0.95-i18n-warning.patch
new file mode 100644
index 000000000000..2e189a233caf
--- /dev/null
+++ b/app-office/kraft/files/kraft-0.95-i18n-warning.patch
@@ -0,0 +1,35 @@
+From 1e8f15a6c54c0c29cb463deacefd1fe8b32ad41d Mon Sep 17 00:00:00 2001
+From: Klaas Freitag <kraft@freisturz.de>
+Date: Wed, 2 Sep 2020 18:32:14 +0200
+Subject: [PATCH] Fix call to i18n - same problem as before....
+
+Fixes #85
+---
+ src/prefsdialog.cpp | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/src/prefsdialog.cpp b/src/prefsdialog.cpp
+index 13b4bcb..ddce27d 100644
+--- a/src/prefsdialog.cpp
++++ b/src/prefsdialog.cpp
+@@ -335,15 +335,15 @@ QWidget* PrefsDialog::docTab()
+ const QDate d = QDate::currentDate();
+ mCbDateFormats->setToolTip( i18n( "The default date format for documents." ) );
+ QString formattedDate = d.toString(Qt::ISODate);
+- mCbDateFormats->insertItem( 0, i18n("ISO-Format: %1").arg(formattedDate));
++ mCbDateFormats->insertItem( 0, i18n("ISO-Format: %1", formattedDate));
+ formattedDate = d.toString(Qt::DefaultLocaleShortDate);
+- mCbDateFormats->insertItem( 1, i18n("Short-Date: %1").arg(formattedDate));
++ mCbDateFormats->insertItem( 1, i18n("Short-Date: %1", formattedDate));
+ formattedDate = d.toString(Qt::DefaultLocaleLongDate);
+- mCbDateFormats->insertItem( 2, i18n("Long-Date: %1").arg(formattedDate));
++ mCbDateFormats->insertItem( 2, i18n("Long-Date: %1", formattedDate));
+ formattedDate = d.toString(Qt::RFC2822Date);
+- mCbDateFormats->insertItem( 3, i18n("RFC 2822-Format: %1").arg(formattedDate));
++ mCbDateFormats->insertItem( 3, i18n("RFC 2822-Format: %1", formattedDate));
+ formattedDate = d.toString("dd.MM.yyyy");
+- mCbDateFormats->insertItem( 4, i18n("\"German Format\": %1").arg(formattedDate));
++ mCbDateFormats->insertItem( 4, i18n("\"German Format\": %1", formattedDate));
+ mCbDateFormats->insertItem( 5, i18n("Custom Setting in Settingsfile"));
+ vboxLay->addLayout( butLay );
+
diff --git a/app-office/kraft/kraft-0.95.ebuild b/app-office/kraft/kraft-0.95.ebuild
new file mode 100644
index 000000000000..c9690d97cef7
--- /dev/null
+++ b/app-office/kraft/kraft-0.95.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit ecm
+
+DESCRIPTION="Software to manage quotes and invoices in small enterprises"
+HOMEPAGE="https://www.volle-kraft-voraus.de/"
+SRC_URI="https://github.com/dragotin/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~x86"
+IUSE="pim"
+
+DEPEND="
+ dev-cpp/ctemplate
+ dev-libs/grantlee:5
+ dev-qt/qtgui:5
+ dev-qt/qtsql:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ kde-frameworks/kconfig:5
+ kde-frameworks/kcontacts:5
+ kde-frameworks/ki18n:5
+ pim? (
+ >=kde-apps/akonadi-19.04.3:5
+ >=kde-apps/akonadi-contacts-19.04.3:5
+ kde-frameworks/kcoreaddons:5
+ )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS Changes.txt README.md Releasenotes.txt TODO )
+
+PATCHES=( "${FILESDIR}/${P}-i18n-warning.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_Asciidoctor=ON
+ $(cmake_use_find_package pim KF5Akonadi)
+ $(cmake_use_find_package pim KF5AkonadiContact)
+ )
+
+ ecm_src_configure
+}