summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office')
-rw-r--r--app-office/gnucash/files/gnucash-5.3-include-algorithm.patch12
-rw-r--r--app-office/gnucash/gnucash-5.3.ebuild3
2 files changed, 15 insertions, 0 deletions
diff --git a/app-office/gnucash/files/gnucash-5.3-include-algorithm.patch b/app-office/gnucash/files/gnucash-5.3-include-algorithm.patch
new file mode 100644
index 000000000000..d9998c8c66ed
--- /dev/null
+++ b/app-office/gnucash/files/gnucash-5.3-include-algorithm.patch
@@ -0,0 +1,12 @@
+diff --git a/libgnucash/engine/gnc-option-impl.hpp b/libgnucash/engine/gnc-option-impl.hpp
+index 4ebaa36..4d157d5 100644
+--- a/libgnucash/engine/gnc-option-impl.hpp
++++ b/libgnucash/engine/gnc-option-impl.hpp
+@@ -49,6 +49,7 @@
+ #include <variant>
+ #include <iostream>
+ #include <limits>
++#include <algorithm>
+
+ #include "gnc-option-uitype.hpp"
+
diff --git a/app-office/gnucash/gnucash-5.3.ebuild b/app-office/gnucash/gnucash-5.3.ebuild
index 9767e2a6665a..e8c2e7d7026e 100644
--- a/app-office/gnucash/gnucash-5.3.ebuild
+++ b/app-office/gnucash/gnucash-5.3.ebuild
@@ -108,6 +108,9 @@ PATCHES=(
# This is only to prevent webkit2gtk-4 from being selected.
# https://bugs.gentoo.org/893676
"${FILESDIR}/${PN}-5.0-webkit2gtk-4.1.patch"
+
+ # GCC 14 no longer includes <algorithm> by default, this is fixed in 5.5
+ "${FILESDIR}/${PN}-5.3-include-algorithm.patch"
)
# guile generates ELF files without use of C or machine code