summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/usbmuxd/Manifest1
-rw-r--r--app-pda/usbmuxd/usbmuxd-1.1.1_p20231011.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/app-pda/usbmuxd/Manifest b/app-pda/usbmuxd/Manifest
index 36324db90938..9b037fbf4578 100644
--- a/app-pda/usbmuxd/Manifest
+++ b/app-pda/usbmuxd/Manifest
@@ -1 +1,2 @@
DIST usbmuxd-1.1.1.tar.bz2 345290 BLAKE2B 580dd4e2fb05d6c4803d774f7d43c8399219d8f0ce4191428cb4fccffcc941894d0381d5f0746997570dd24e395af3dda340b1910827f9c5ace7e2d9cc176c6a SHA512 0e8829c93aac147a6b949fe95592d6ad9ea36e1c04676cb85accb4670a65b31065706fc438556def17b55850081d6c07deb325ca02b9853335b6e0b1049ba1da
+DIST usbmuxd-1.1.1_p20231011.tar.gz 65638 BLAKE2B 68bfdcdf907241fbf3b8b41133e11f3b08c5007417a1ea86f5428a5c11f480f9e6a6a9073080976d84ed14b456f61e19ef2b2f161d5b1ec19367fe01eb89b435 SHA512 dfe2e39496aa6841aaa7c02dc5ad5425f4199d5e5ccf560438e5f07fff9050124918ce99a1b2e22fc5b8718e091aff81ff209467de16701a14279e994c5ceefe
diff --git a/app-pda/usbmuxd/usbmuxd-1.1.1_p20231011.ebuild b/app-pda/usbmuxd/usbmuxd-1.1.1_p20231011.ebuild
new file mode 100644
index 000000000000..1e79cbeeeadb
--- /dev/null
+++ b/app-pda/usbmuxd/usbmuxd-1.1.1_p20231011.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools systemd udev
+
+MY_COMMIT=360619c5f721f93f0b9d8af1a2df0b926fbcf281
+
+DESCRIPTION="USB multiplex daemon for use with Apple iPhone/iPod Touch devices"
+HOMEPAGE="https://libimobiledevice.org/"
+SRC_URI="https://github.com/libimobiledevice/usbmuxd/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${MY_COMMIT}
+
+# src/utils.h is LGPL-2.1+, rest is found in COPYING*
+LICENSE="|| ( GPL-2 GPL-3 ) LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="selinux systemd"
+
+DEPEND="
+ acct-user/usbmux
+ >=app-pda/libimobiledevice-1.3.0:=
+ app-pda/libimobiledevice-glue:=
+ >=app-pda/libplist-2.3:=
+ virtual/libusb:1=
+"
+RDEPEND="
+ ${DEPEND}
+ virtual/udev
+ selinux? ( sec-policy/selinux-usbmuxd )
+ systemd? ( sys-apps/systemd )
+"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ echo ${PV} > "${S}"/.tarball-version
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ "$(use_with systemd)" \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" \
+ --with-udevrulesdir="$(get_udevdir)"/rules.d
+}
+
+pkg_postrm() {
+ udev_reload
+}
+
+pkg_postinst() {
+ udev_reload
+}