summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/conf-update/conf-update-1.0.3-r1.ebuild')
-rw-r--r--app-portage/conf-update/conf-update-1.0.3-r1.ebuild30
1 files changed, 17 insertions, 13 deletions
diff --git a/app-portage/conf-update/conf-update-1.0.3-r1.ebuild b/app-portage/conf-update/conf-update-1.0.3-r1.ebuild
index b599d25db4be..53603d63c761 100644
--- a/app-portage/conf-update/conf-update-1.0.3-r1.ebuild
+++ b/app-portage/conf-update/conf-update-1.0.3-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="${PN} is a ncurses-based config management utility"
HOMEPAGE="https://gitweb.gentoo.org/proj/conf-update.git/"
@@ -12,20 +12,24 @@ SRC_URI="https://gitweb.gentoo.org/proj/${PN}.git/snapshot/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE="colordiff libressl"
+IUSE="colordiff"
-RDEPEND=">=dev-libs/glib-2.6
- sys-libs/ncurses:0
- !libressl? ( dev-libs/openssl:0 )
- libressl? ( dev-libs/libressl )
- colordiff? ( app-misc/colordiff )"
-DEPEND="virtual/pkgconfig
- ${RDEPEND}"
+RDEPEND="
+ dev-libs/glib
+ sys-libs/ncurses:0
+ colordiff? ( app-misc/colordiff )
+ dev-libs/openssl:0=
+ "
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
src_prepare() {
- sed -i -e "s/\$Rev:.*\\$/${PVR}/" "${S}"/"${PN}".h || die
+ default
+ sed -i -e "s/\$Rev:.*\\$/${PVR}/" ${PN}.h || die
if use colordiff ; then
- sed -i -e "s/diff_tool=diff/diff_tool=colordiff/" ${PN}.conf \ die 'colordiff-sed failed'
+ sed -i -e "s/diff_tool=diff/diff_tool=colordiff/" ${PN}.conf || die
fi
tc-export PKG_CONFIG
}