summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/diffmask/diffmask-0.3.3-r5.ebuild')
-rw-r--r--app-portage/diffmask/diffmask-0.3.3-r5.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/app-portage/diffmask/diffmask-0.3.3-r5.ebuild b/app-portage/diffmask/diffmask-0.3.3-r5.ebuild
new file mode 100644
index 000000000000..a4cfe46a89af
--- /dev/null
+++ b/app-portage/diffmask/diffmask-0.3.3-r5.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A utility to maintain package.unmask entries up-to-date with masks"
+HOMEPAGE="https://github.com/projg2/diffmask/"
+SRC_URI="https://github.com/projg2/diffmask/releases/download/${P}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~mips ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ sys-apps/portage[${PYTHON_USEDEP}]
+"