summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/euscan/euscan-0.1.1-r2.ebuild')
-rw-r--r--app-portage/euscan/euscan-0.1.1-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-portage/euscan/euscan-0.1.1-r2.ebuild b/app-portage/euscan/euscan-0.1.1-r2.ebuild
new file mode 100644
index 000000000000..27566cc7555f
--- /dev/null
+++ b/app-portage/euscan/euscan-0.1.1-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml"
+
+inherit distutils-r1
+
+DESCRIPTION="Ebuild upstream scan utility"
+HOMEPAGE="https://github.com/iksaif/euscan"
+SRC_URI="https://dev.gentoo.org/~hwoarang/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ || (
+ sys-apps/portage[${PYTHON_USEDEP}]
+ sys-apps/portage-mgorny[${PYTHON_USEDEP}]
+ )"
+RDEPEND="${DEPEND}
+ >=app-portage/gentoolkit-0.2.8[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup:python-2[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ python_setup
+ echo VERSION="${PV}" "${PYTHON}" setup.py set_version
+ VERSION="${PV}" "${PYTHON}" setup.py set_version
+ distutils-r1_python_prepare_all
+}