summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/g-cpan/g-cpan-9999.ebuild')
-rw-r--r--app-portage/g-cpan/g-cpan-9999.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/app-portage/g-cpan/g-cpan-9999.ebuild b/app-portage/g-cpan/g-cpan-9999.ebuild
index 1d1c113c9dd9..1ff7291fd259 100644
--- a/app-portage/g-cpan/g-cpan-9999.ebuild
+++ b/app-portage/g-cpan/g-cpan-9999.ebuild
@@ -32,15 +32,15 @@ RDEPEND="${DEPEND}
src_install() {
perl-module_src_install
- diropts "-m0755"
+ diropts -m0775 -o portage -g portage
dodir "/var/tmp/g-cpan"
dodir "/var/log/g-cpan"
keepdir "/var/log/g-cpan"
}
pkg_postinst() {
- elog "You may wish to adjust the permissions on /var/tmp/g-cpan"
- elog "if you have users besides root expecting to use g-cpan."
+ elog "If you want to use g-cpan besides root you may wish to"
+ elog " adjust the permissions on /var/tmp/g-cpan or add users into portage group."
elog "Please note that some CPAN packages need additional manual"
elog "parameters or tweaking, due to bugs in their build systems."
}