summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/g-cpan/g-cpan-9999.ebuild')
-rw-r--r--app-portage/g-cpan/g-cpan-9999.ebuild25
1 files changed, 14 insertions, 11 deletions
diff --git a/app-portage/g-cpan/g-cpan-9999.ebuild b/app-portage/g-cpan/g-cpan-9999.ebuild
index fca42099a130..245e333b5463 100644
--- a/app-portage/g-cpan/g-cpan-9999.ebuild
+++ b/app-portage/g-cpan/g-cpan-9999.ebuild
@@ -1,16 +1,15 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit perl-module
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://github.com/gentoo-perl/g-cpan.git"
inherit git-r3
- SRC_URI=""
else
- SRC_URI="https://github.com/gentoo-perl/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/gentoo-perl/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
fi
@@ -22,7 +21,7 @@ SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"
-COMMONDEPEND="
+COMMON_DEPEND="
dev-perl/Config-Tiny
virtual/perl-File-Path
virtual/perl-File-Spec
@@ -34,24 +33,28 @@ COMMONDEPEND="
virtual/perl-Term-ANSIColor
>=dev-perl/YAML-0.60
"
-RDEPEND="${COMMONDEPEND}
+RDEPEND="
+ ${COMMON_DEPEND}
>=sys-apps/portage-2.0.0
"
-DEPEND="${COMMONDEPEND}
+BDEPEND="
+ ${COMMON_DEPEND}
virtual/perl-ExtUtils-MakeMaker
test? ( >=virtual/perl-Test-Simple-0.940.0 )
"
src_install() {
perl-module_src_install
+
if ! use prefix; then
diropts -m0775 -o portage -g portage
else
diropts -m0775
fi
- dodir "/var/tmp/g-cpan"
- dodir "/var/log/g-cpan"
- keepdir "/var/log/g-cpan"
+
+ dodir /var/tmp/g-cpan
+ dodir /var/log/g-cpan
+ keepdir /var/log/g-cpan
}
pkg_postinst() {