summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/gemato/gemato-9999.ebuild')
-rw-r--r--app-portage/gemato/gemato-9999.ebuild29
1 files changed, 17 insertions, 12 deletions
diff --git a/app-portage/gemato/gemato-9999.ebuild b/app-portage/gemato/gemato-9999.ebuild
index d832ec857b65..2930ef35cc4e 100644
--- a/app-portage/gemato/gemato-9999.ebuild
+++ b/app-portage/gemato/gemato-9999.ebuild
@@ -1,36 +1,41 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{6..9} pypy3 )
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
PYTHON_REQ_USE='threads(+)'
inherit distutils-r1 git-r3
DESCRIPTION="Stand-alone Manifest generation & verification tool"
-HOMEPAGE="https://github.com/mgorny/gemato"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/mgorny/gemato.git"
+HOMEPAGE="
+ https://github.com/projg2/gemato/
+ https://pypi.org/project/gemato/
+"
+EGIT_REPO_URI="https://github.com/projg2/gemato.git"
LICENSE="BSD-2"
SLOT="0"
-KEYWORDS=""
-IUSE="+gpg tools"
+IUSE="+gpg pretty-log tools"
RDEPEND="
gpg? (
>=app-crypt/gnupg-2.2.20-r1
dev-python/requests[${PYTHON_USEDEP}]
- )"
+ )
+ pretty-log? (
+ dev-python/rich[${PYTHON_USEDEP}]
+ )
+"
BDEPEND="
test? (
>=app-crypt/gnupg-2.2.20-r1
- >=dev-python/pytest-5[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/responses[${PYTHON_USEDEP}]
- )"
+ )
+"
distutils_enable_tests pytest