summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/gentoopm')
-rw-r--r--app-portage/gentoopm/Manifest3
-rw-r--r--app-portage/gentoopm/gentoopm-0.3.1.ebuild28
-rw-r--r--app-portage/gentoopm/gentoopm-0.3.2.ebuild28
-rw-r--r--app-portage/gentoopm/gentoopm-0.5.0.ebuild35
-rw-r--r--app-portage/gentoopm/gentoopm-9999.ebuild32
-rw-r--r--app-portage/gentoopm/metadata.xml7
6 files changed, 57 insertions, 76 deletions
diff --git a/app-portage/gentoopm/Manifest b/app-portage/gentoopm/Manifest
index 1a8ecab591d8..109f2f94f3cb 100644
--- a/app-portage/gentoopm/Manifest
+++ b/app-portage/gentoopm/Manifest
@@ -1,2 +1 @@
-DIST gentoopm-0.3.1.tar.gz 37897 BLAKE2B dd5499787bcc5c46ae3b559f3af4a5af5b4ca81a312e926149c587cac0391c51dbe61ac42d2bc19eb83cedc168486e9c30ddd6fbf4ae10ffd9719aefa2f54cd3 SHA512 e1a3a7929ae83d813dd0b03f0548f033e8e51b766aaddb653027398fb618819de6237e2ba1c0542defc9d62e71e8495aa10152cbc47a4e521f7cbaeda3ea4354
-DIST gentoopm-0.3.2.tar.gz 38430 BLAKE2B df8536b384cdad754894d65b605ab688cedc09430bcc3cd0821ed1ae9a93d0cb5e7b076715edf6eaed6bbf5ffc9088fb14d8bd5a04c3809c38ce05c6ed106bb9 SHA512 d99034af2efada3647117c75d5602bc5878a8f0e79d1c6b502fdb0fa272f7b9148afbbe4d379a2957a7db6694b4001158e2dfce8e3a4f97692e20a803417f571
+DIST gentoopm-0.5.0.gh.tar.gz 36710 BLAKE2B 12819b645154fd9ea68cd2b4f605c8ea3fcbec5005754acfd0e96081527c66a04d37ab73c8c967f5989abf97f155263c98ccb3ce6e0bc1fe9d9e5dbbc639c902 SHA512 b5ff3f79c54028b8d1442414353e4872fb0249c75ce9dedff9c907bd1307841996c254b502d18f32469d938a62add2acdd77080c693069a4b01afecca382a67e
diff --git a/app-portage/gentoopm/gentoopm-0.3.1.ebuild b/app-portage/gentoopm/gentoopm-0.3.1.ebuild
deleted file mode 100644
index b4fdefc2f9f3..000000000000
--- a/app-portage/gentoopm/gentoopm-0.3.1.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{6..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="A common interface to Gentoo package managers"
-HOMEPAGE="https://github.com/mgorny/gentoopm/"
-SRC_URI="https://github.com/mgorny/gentoopm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="amd64 arm ~mips x86"
-IUSE=""
-
-RDEPEND="
- || (
- >=sys-apps/pkgcore-0.9.4[${PYTHON_USEDEP}]
- >=sys-apps/portage-2.1.10.3[${PYTHON_USEDEP}] )"
-PDEPEND="app-eselect/eselect-package-manager"
-
-python_test() {
- esetup.py test
-}
diff --git a/app-portage/gentoopm/gentoopm-0.3.2.ebuild b/app-portage/gentoopm/gentoopm-0.3.2.ebuild
deleted file mode 100644
index 5582cd45b7ef..000000000000
--- a/app-portage/gentoopm/gentoopm-0.3.2.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{6..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="A common interface to Gentoo package managers"
-HOMEPAGE="https://github.com/mgorny/gentoopm/"
-SRC_URI="https://github.com/mgorny/gentoopm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~mips ~x86"
-IUSE=""
-
-RDEPEND="
- || (
- >=sys-apps/pkgcore-0.9.4[${PYTHON_USEDEP}]
- >=sys-apps/portage-2.1.10.3[${PYTHON_USEDEP}] )"
-PDEPEND="app-eselect/eselect-package-manager"
-
-python_test() {
- esetup.py test
-}
diff --git a/app-portage/gentoopm/gentoopm-0.5.0.ebuild b/app-portage/gentoopm/gentoopm-0.5.0.ebuild
new file mode 100644
index 000000000000..b410c9550d62
--- /dev/null
+++ b/app-portage/gentoopm/gentoopm-0.5.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A common interface to Gentoo package managers"
+HOMEPAGE="
+ https://github.com/projg2/gentoopm/
+ https://pypi.org/project/gentoopm/
+"
+SRC_URI="
+ https://github.com/projg2/gentoopm/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ~mips ~ppc ppc64 ~riscv sparc x86 ~x64-macos"
+
+RDEPEND="
+ || (
+ >=sys-apps/pkgcore-0.12.19[${PYTHON_USEDEP}]
+ >=sys-apps/portage-2.1.10.3[${PYTHON_USEDEP}]
+ )
+"
+PDEPEND="
+ app-eselect/eselect-package-manager
+"
+
+distutils_enable_tests pytest
diff --git a/app-portage/gentoopm/gentoopm-9999.ebuild b/app-portage/gentoopm/gentoopm-9999.ebuild
index 2dc9a2c3f698..216267845773 100644
--- a/app-portage/gentoopm/gentoopm-9999.ebuild
+++ b/app-portage/gentoopm/gentoopm-9999.ebuild
@@ -1,29 +1,31 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
-EGIT_REPO_URI="https://github.com/mgorny/gentoopm.git"
inherit distutils-r1 git-r3
DESCRIPTION="A common interface to Gentoo package managers"
-HOMEPAGE="https://github.com/mgorny/gentoopm/"
-SRC_URI=""
+HOMEPAGE="
+ https://github.com/projg2/gentoopm/
+ https://pypi.org/project/gentoopm/
+"
+EGIT_REPO_URI="https://github.com/projg2/gentoopm.git"
LICENSE="BSD-2"
SLOT="0"
-KEYWORDS=""
-IUSE=""
RDEPEND="
|| (
- >=sys-apps/pkgcore-0.9.4[${PYTHON_USEDEP}]
- >=sys-apps/portage-2.1.10.3[${PYTHON_USEDEP}] )"
-PDEPEND="app-eselect/eselect-package-manager"
+ >=sys-apps/pkgcore-0.12.19[${PYTHON_USEDEP}]
+ >=sys-apps/portage-2.1.10.3[${PYTHON_USEDEP}]
+ )
+"
+PDEPEND="
+ app-eselect/eselect-package-manager
+"
-python_test() {
- esetup.py test
-}
+distutils_enable_tests pytest
diff --git a/app-portage/gentoopm/metadata.xml b/app-portage/gentoopm/metadata.xml
index 96a81859dd9c..4eaa4cb48702 100644
--- a/app-portage/gentoopm/metadata.xml
+++ b/app-portage/gentoopm/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>mgorny@gentoo.org</email>
@@ -11,7 +11,8 @@
<email>mgorny@gentoo.org</email>
<name>Michał Górny</name>
</maintainer>
- <bugs-to>https://github.com/mgorny/gentoopm/issues/</bugs-to>
- <remote-id type="github">mgorny/gentoopm</remote-id>
+ <bugs-to>https://github.com/projg2/gentoopm/issues/</bugs-to>
+ <remote-id type="github">projg2/gentoopm</remote-id>
+ <remote-id type="pypi">gentoopm</remote-id>
</upstream>
</pkgmetadata>