summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/gverify/gverify-1.ebuild')
-rw-r--r--app-portage/gverify/gverify-1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-portage/gverify/gverify-1.ebuild b/app-portage/gverify/gverify-1.ebuild
new file mode 100644
index 000000000000..3564e46d3051
--- /dev/null
+++ b/app-portage/gverify/gverify-1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} )
+inherit python-single-r1
+
+DESCRIPTION="gentoo.git signature verification tool"
+HOMEPAGE="https://github.com/mgorny/gverify"
+SRC_URI="https://github.com/mgorny/gverify/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}
+ app-crypt/gnupg
+ dev-vcs/git"
+DEPEND="${PYTHON_DEPS}"
+
+src_compile() {
+ emake PREFIX="${EPREFIX}"/usr
+}
+
+src_install() {
+ emake install DESTDIR="${D}" PREFIX=/usr
+ dodoc README
+}