summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/hackport/hackport-9999.ebuild')
-rw-r--r--app-portage/hackport/hackport-9999.ebuild109
1 files changed, 72 insertions, 37 deletions
diff --git a/app-portage/hackport/hackport-9999.ebuild b/app-portage/hackport/hackport-9999.ebuild
index 6853550d5f1f..6845afdc9bf7 100644
--- a/app-portage/hackport/hackport-9999.ebuild
+++ b/app-portage/hackport/hackport-9999.ebuild
@@ -1,62 +1,97 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-# ebuild generated by hackport 0.5.1.9999
+# ebuild generated by hackport 0.8.4.0.9999
+#hackport: flags: +cabal-v1,+gentoo-tests,+pedantic
CABAL_FEATURES="test-suite"
EGIT_REPO_URI="https://github.com/gentoo-haskell/hackport.git"
-inherit git-r3 haskell-cabal
+inherit git-r3 haskell-cabal bash-completion-r1
DESCRIPTION="Hackage and Portage integration tool"
-HOMEPAGE="https://github.com/gentoo-haskell/hackport"
+HOMEPAGE="https://github.com/gentoo-haskell/hackport#readme"
-LICENSE="GPL-2"
+LICENSE="GPL-3+"
SLOT="0"
KEYWORDS=""
-IUSE=""
-
-RESTRICT=test # tests are broken: need path to ebuild tree
+IUSE="profile +threads"
+REQUIRED_USE="profile? ( threads ) test? ( threads )"
RDEPEND="
- app-portage/repoman
- dev-haskell/async:=
- dev-haskell/base16-bytestring:=
- dev-haskell/base64-bytestring:=
- dev-haskell/cryptohash:=
- dev-haskell/ed25519:=
- dev-haskell/extensible-exceptions:=
- dev-haskell/hashable:=
- >=dev-haskell/http-4000.0.3:=
- dev-haskell/missingh:=
- dev-haskell/mtl:=
- >=dev-haskell/network-2.6:=
- >=dev-haskell/network-uri-2.6:=
- dev-haskell/old-locale:=
- dev-haskell/old-time:=
- dev-haskell/parsec:=
- dev-haskell/random:=
- dev-haskell/regex-compat:=
- dev-haskell/split:=
- dev-haskell/stm:=
- >=dev-haskell/tar-0.5:=
- >=dev-haskell/xml-1.3.7:=
- dev-haskell/zlib:=
- >=dev-lang/ghc-7.8.2:=
+ >=dev-haskell/async-2.0:=[profile?]
+ >=dev-haskell/base16-bytestring-0.1.1:=[profile?]
+ >=dev-haskell/base64-bytestring-1.0:=[profile?]
+ >=dev-haskell/cryptohash-sha256-0.11:=[profile?]
+ dev-haskell/dlist:=[profile?]
+ >=dev-haskell/echo-0.1.3:=[profile?]
+ >=dev-haskell/ed25519-0.0:=[profile?]
+ >=dev-haskell/edit-distance-0.2.2:=[profile?]
+ dev-haskell/extensible-exceptions:=[profile?]
+ >=dev-haskell/hashable-1.0:=[profile?]
+ >=dev-haskell/http-4000.1.5:=[profile?]
+ dev-haskell/lifted-base:=[profile?]
+ >=dev-haskell/lukko-0.1:=[profile?]
+ dev-haskell/monad-control:=[profile?]
+ >=dev-haskell/network-3.0:=[profile?]
+ >=dev-haskell/network-uri-2.6.0.2:=[profile?]
+ dev-haskell/optparse-applicative:=[profile?]
+ >=dev-haskell/parallel-3.2.1.0:=[profile?]
+ >=dev-haskell/parsec-3.1.13.0:=[profile?]
+ dev-haskell/parser-combinators:=[profile?]
+ dev-haskell/prettyprinter:=[profile?]
+ dev-haskell/quickcheck:=
+ >=dev-haskell/random-1.2:=[profile?]
+ >=dev-haskell/regex-base-0.94.0.0:=[profile?]
+ >=dev-haskell/regex-posix-0.96.0.0:=[profile?]
+ >=dev-haskell/resolv-0.1.1:=[profile?]
+ >=dev-haskell/safe-exceptions-0.1.7.0:=[profile?]
+ dev-haskell/split:=[profile?]
+ >=dev-haskell/tar-0.5.0.3:=[profile?]
+ >=dev-haskell/text-1.2.3.0:=[profile?]
+ dev-haskell/xml:=[profile?]
+ >=dev-haskell/zlib-0.5.3:=[profile?]
+ >=dev-lang/ghc-8.10.6:=[profile?]
"
DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.18.1.3
- test? ( dev-haskell/hunit )
+ >=dev-haskell/cabal-3.2.1.0
+ test? (
+ dev-haskell/base-compat
+ >=dev-haskell/cabal-doctest-1.0
+ >=dev-haskell/doctest-0.8
+ dev-haskell/glob
+ >=dev-haskell/hspec-2.0
+ dev-haskell/hunit
+ >=dev-haskell/quickcheck-2.0
+ )
"
src_prepare() {
- default
- sed -e 's/^Version:.*/&.9999/' -i ${PN}.cabal || die # just to distinct from release install
+ haskell-cabal_src_prepare
+ sed -e 's/^version:.*/&.9999/' -i ${PN}.cabal || die # just to distinguish from release install
+}
+
+src_configure() {
+ if use test; then
+ export GHC_BOOTSTRAP_PACKAGES=(
+ cabal-doctest
+ )
+ fi
+
+ haskell-cabal_src_configure \
+ --flag=cabal-v1 \
+ --flag=gentoo-tests \
+ --flag=pedantic \
+ $(cabal_flag profile profile) \
+ $(cabal-flag threads threads)
}
src_install() {
haskell-cabal_src_install
doman man/hackport.1
+
+ # We only install bash completion scripts currently
+ newbashcomp "${FILESDIR}/${PN}.bash.completion" "${PN}"
}