summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/iwdevtools/iwdevtools-9999.ebuild')
-rw-r--r--app-portage/iwdevtools/iwdevtools-9999.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/app-portage/iwdevtools/iwdevtools-9999.ebuild b/app-portage/iwdevtools/iwdevtools-9999.ebuild
index 9352ae24fd78..0af26d4a3147 100644
--- a/app-portage/iwdevtools/iwdevtools-9999.ebuild
+++ b/app-portage/iwdevtools/iwdevtools-9999.ebuild
@@ -22,14 +22,15 @@ RDEPEND="
sys-apps/file
sys-apps/portage
sys-apps/util-linux"
-BDEPEND="
- test? (
- ${RDEPEND}
- dev-util/libabigail
- )"
+BDEPEND="test? ( ${RDEPEND} )"
src_configure() {
- meson_src_configure -Ddocdir=${PF} $(meson_use test)
+ local emesonargs=(
+ -Ddocdir=${PF}
+ -Deprefix="${EPREFIX}"
+ $(meson_use test)
+ )
+ meson_src_configure
}
pkg_postinst() {
@@ -40,7 +41,7 @@ pkg_postinst() {
elog "at ${EROOT}/usr/share/${PN}. If not already using a bashrc, you can use"
elog "the example bashrc directly by creating a symlink:"
elog
- elog " ln -s ../../../usr/share/${PN}/bashrc ${EROOT}/etc/portage/bashrc"
+ elog " ln -s ../../usr/share/${PN}/bashrc ${EROOT}/etc/portage/bashrc"
elog
elog "See ${EROOT}/usr/share/doc/${PF}/README.rst* for info on tools."
fi