summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/pfl')
-rw-r--r--app-portage/pfl/Manifest3
-rw-r--r--app-portage/pfl/metadata.xml6
-rw-r--r--app-portage/pfl/pfl-3.5.2.ebuild (renamed from app-portage/pfl/pfl-3.1.ebuild)22
-rw-r--r--app-portage/pfl/pfl-3.5.3.ebuild49
4 files changed, 65 insertions, 15 deletions
diff --git a/app-portage/pfl/Manifest b/app-portage/pfl/Manifest
index 0e1adeb7edf0..bd68018f93a7 100644
--- a/app-portage/pfl/Manifest
+++ b/app-portage/pfl/Manifest
@@ -1 +1,2 @@
-DIST pfl-3.1.tar.gz 5521 BLAKE2B fdc6e82c5d61d694a188c479b0566aafc507bcc2bbd1f176cd2771586b13de86a43a5d2e156beb4c9b5d10cd718046a05fce099894430c8f3d04c0922078e988 SHA512 b2bf79445a5b15caf339106f376d64accf5aad2c60038ba88180d64ce49e23dc3015efa2fcbeec886ba591cada053dfdc96873bda71b092be4622608062b6dcc
+DIST pfl-3.5.2.tar.gz 21248 BLAKE2B 28f4f05bc533f4b27cdbef7f2706ed99f885983e4f9e4f2580e07b772bef471eeca197a41d03059e28c2053869de4cb5295a9923dcba6f598bbf6e6be5e57185 SHA512 5f38b627cd5928396fe8202dd822756ed63b6dd80d98d1ee3da9998eb750070e9a921d652bbc7ed852e4944005f9d6c61c14c67be01c591f5c82ca50f869465e
+DIST pfl-3.5.3.tar.gz 21303 BLAKE2B b7b4bf57b3ab7b8a118b84f412481485570274c9f37947c86d104b8e34a5fcac7748a3dbc928e66193813fec36a0a630a6ae7eb4a9cb25105b4abfc4d5b85344 SHA512 3e6e18cb80b054379bf938cfc02e44f9c26bdf959bceb9c85ba2f97cd60c5c9e8bf030fac093f7e0a9314463328b724ed812424298ffd9b9a146fb5900382d49
diff --git a/app-portage/pfl/metadata.xml b/app-portage/pfl/metadata.xml
index 534265d6749f..7369356d2377 100644
--- a/app-portage/pfl/metadata.xml
+++ b/app-portage/pfl/metadata.xml
@@ -1,15 +1,17 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>billie@gentoo.org</email>
<name>Daniel Pielmeier</name>
</maintainer>
+ <stabilize-allarches/>
<upstream>
<maintainer>
<email>bugs@portagefilelist.de</email>
- <name>Daniel Buschke</name>
+ <name>Johannes Keßler</name>
</maintainer>
+ <remote-id type="github">portagefilelist/client</remote-id>
</upstream>
<use>
<flag name="network-cron">Adds a cron job which does a weekly submit of the package database</flag>
diff --git a/app-portage/pfl/pfl-3.1.ebuild b/app-portage/pfl/pfl-3.5.2.ebuild
index 2f56537889c6..a3a178118186 100644
--- a/app-portage/pfl/pfl-3.1.ebuild
+++ b/app-portage/pfl/pfl-3.5.2.ebuild
@@ -1,34 +1,32 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{6,7,8} )
-PYTHON_REQ_USE="xml"
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="xml(+)"
inherit distutils-r1 systemd
DESCRIPTION="Searchable online file/package database for Gentoo"
-HOMEPAGE="http://www.portagefilelist.de https://github.com/portagefilelist/client"
+HOMEPAGE="https://www.portagefilelist.de https://github.com/portagefilelist/client"
SRC_URI="https://github.com/portagefilelist/client/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/client-${PV}"
+
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 arm ~hppa ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
+KEYWORDS="amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
IUSE="+network-cron"
-DEPEND=""
RDEPEND="
- ${DEPEND}
dev-python/requests[${PYTHON_USEDEP}]
- net-misc/curl
+ dev-python/termcolor[${PYTHON_USEDEP}]
sys-apps/portage[${PYTHON_USEDEP}]
network-cron? ( sys-apps/util-linux[caps] )
"
-S="${WORKDIR}/client-${PV}"
-
python_install_all() {
if use network-cron ; then
exeinto /etc/cron.weekly
diff --git a/app-portage/pfl/pfl-3.5.3.ebuild b/app-portage/pfl/pfl-3.5.3.ebuild
new file mode 100644
index 000000000000..287a582296b9
--- /dev/null
+++ b/app-portage/pfl/pfl-3.5.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 systemd
+
+DESCRIPTION="Searchable online file/package database for Gentoo"
+HOMEPAGE="https://www.portagefilelist.de https://github.com/portagefilelist/client"
+SRC_URI="https://github.com/portagefilelist/client/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+S="${WORKDIR}/client-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="+network-cron"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/termcolor[${PYTHON_USEDEP}]
+ sys-apps/portage[${PYTHON_USEDEP}]
+ network-cron? ( sys-apps/util-linux[caps] )
+"
+
+python_install_all() {
+ if use network-cron ; then
+ exeinto /etc/cron.weekly
+ doexe cron/pfl
+ fi
+
+ systemd_dounit systemd/pfl.{service,timer}
+
+ keepdir /var/lib/${PN}
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ if [[ ! -e "${EROOT}/var/lib/${PN}/pfl.info" ]]; then
+ touch "${EROOT}/var/lib/${PN}/pfl.info" || die
+ fi
+ chown -R portage:portage "${EROOT}/var/lib/${PN}" || die
+ chmod 775 "${EROOT}/var/lib/${PN}" || die
+}