summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/pram')
-rw-r--r--app-portage/pram/Manifest3
-rw-r--r--app-portage/pram/metadata.xml6
-rw-r--r--app-portage/pram/pram-10.ebuild (renamed from app-portage/pram/pram-9.ebuild)8
-rw-r--r--app-portage/pram/pram-11.ebuild33
4 files changed, 42 insertions, 8 deletions
diff --git a/app-portage/pram/Manifest b/app-portage/pram/Manifest
index e514e0db3124..0cc5e9ea7c82 100644
--- a/app-portage/pram/Manifest
+++ b/app-portage/pram/Manifest
@@ -1 +1,2 @@
-DIST pram-9.tar.gz 8206 BLAKE2B cf490edd53d307e5d9c715d0ca68e38d04ebd5a1dc75f89232605ac5cc9cbc9567b3895b1e2445a14c5acf119f054dc2b982ea7b9949177519a70062e648272b SHA512 a9e718ca0cdc93a67f442f2db5dd6a854357aa493ad7836e5d75ede68c3fad06d2343f1ee34f00bb66203d41575c7773999772f9251a9a2d6fc74702ce875c4d
+DIST pram-10.tar.gz 8292 BLAKE2B a5d6cbef942127479709b3306f20aaed696ac60d34dba53cbe15377c42d785d43c11b36889ce67a674d3ce355529c267e896cded714ef6f042cf77a3721100f8 SHA512 5dc11ef82ed84b5170f094ccd5e9515affc250f9efdc24be52edc7aa1720cda664a1a394301e0d8fc18a7f8c839a1147d29eca5f758d922a5ebbed6d166394f2
+DIST pram-11.tar.gz 14267 BLAKE2B f7716575b9b4b91837d6ad1a8783f7f1963cc978ad3c636c50123f247c5f9aea8eb1d21c249794164fc1951b28a517989d19158fcd6c60347cf1e5b477a3badc SHA512 5f8cb9f4f0f95871af8f4d2e86ab26b06e50182e136c7779ace7e7ad4344d20d015986c25bbe763d8c82fb2f98e9770a836302393bc736c067286f485eca93c1
diff --git a/app-portage/pram/metadata.xml b/app-portage/pram/metadata.xml
index 6dde7de270a0..8a8dbe18503f 100644
--- a/app-portage/pram/metadata.xml
+++ b/app-portage/pram/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>mgorny@gentoo.org</email>
@@ -11,7 +11,7 @@
<email>mgorny@gentoo.org</email>
<name>Michał Górny</name>
</maintainer>
- <bugs-to>https://github.com/mgorny/pram/issues/</bugs-to>
- <remote-id type="github">mgorny/pram</remote-id>
+ <bugs-to>https://github.com/projg2/pram/issues/</bugs-to>
+ <remote-id type="github">projg2/pram</remote-id>
</upstream>
</pkgmetadata>
diff --git a/app-portage/pram/pram-9.ebuild b/app-portage/pram/pram-10.ebuild
index bf227cb8aae6..25e440cef3bf 100644
--- a/app-portage/pram/pram-9.ebuild
+++ b/app-portage/pram/pram-10.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2019-2020 Gentoo Authors
+# Copyright 2019-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -6,12 +6,12 @@ EAPI=7
inherit meson
DESCRIPTION="Tool to ease merging Pull Requests and git patches"
-HOMEPAGE="https://github.com/mgorny/pram"
-SRC_URI="https://github.com/mgorny/pram/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/projg2/pram"
+SRC_URI="https://github.com/projg2/pram/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0"
-KEYWORDS="amd64 ~arm64 ppc64 x86"
+KEYWORDS="amd64 ~arm64 ppc64 ~riscv x86 ~x64-macos"
IUSE="test"
RESTRICT="!test? ( test )"
diff --git a/app-portage/pram/pram-11.ebuild b/app-portage/pram/pram-11.ebuild
new file mode 100644
index 000000000000..2745ced0fbc7
--- /dev/null
+++ b/app-portage/pram/pram-11.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Tool to ease merging Pull Requests and git patches"
+HOMEPAGE="https://github.com/projg2/pram/"
+SRC_URI="
+ https://github.com/projg2/pram/archive/v${PV}.tar.gz -> ${P}.tar.gz
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-vcs/git
+ net-misc/wget[ssl]
+ virtual/editor
+ !dev-perl/Gentoo-App-Pram
+"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ app-crypt/gnupg
+ >=dev-vcs/git-2.45.0
+ sys-apps/diffutils
+ )
+"