summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/pfl/Manifest1
-rw-r--r--app-portage/pfl/pfl-3.3.1.ebuild49
2 files changed, 0 insertions, 50 deletions
diff --git a/app-portage/pfl/Manifest b/app-portage/pfl/Manifest
index bb2843bb26dc..3069476fb19b 100644
--- a/app-portage/pfl/Manifest
+++ b/app-portage/pfl/Manifest
@@ -1,3 +1,2 @@
DIST pfl-3.2.1.tar.gz 5655 BLAKE2B 1ebfccca48ac090c6467cfd7a63a488a72e723f8f31d9eb5e8494b74666e20f9e4372fed829e0114295210a76ec9debc9fdd5236340a7740eb1ccfbbc5aaa48b SHA512 967ebe2baed50cd1ed0549d000e2bb240e55c0988d74e492f114fe16b328978ad062606e568dcbe65bcb78738388b1447c823bd1fa31a979d10a4be7a5c7984a
-DIST pfl-3.3.1.tar.gz 17810 BLAKE2B 29f180be8b8ca65830da72c191fa38088cdd542340e34f144e8be307deff6689dab9e7abbf1ef6be44fefc95d9c1033d9f6a0a4d423eaa5c9ec29bd9f54ec7a8 SHA512 238933674650ef116c897162894141cbf7c3c1d029453b9226fb0d65138706f89f9a737e44ca7e85a50d7996c1680eb66e5c4357cfcbbb01a29a67398201bda9
DIST pfl-3.4.tar.gz 18651 BLAKE2B 09793883a1ed6f70da2f01fb81cfafa407ed43584a826f2cd8fde6d75b544ed803a220fc517e649774100da32e64d01fad8ff0dcbaff9068f57cdf7bd4414169 SHA512 c21b43f234a778d74e05cd45b7ccb48b131d6998e632d044a4bccc2f772099d02d1c5e7ab75fc6f9deb14e2f1ed1f31bac51e917e628065b4a36d73b8d77336f
diff --git a/app-portage/pfl/pfl-3.3.1.ebuild b/app-portage/pfl/pfl-3.3.1.ebuild
deleted file mode 100644
index a209f77e6ae3..000000000000
--- a/app-portage/pfl/pfl-3.3.1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-PYTHON_REQ_USE="xml(+)"
-
-inherit distutils-r1 systemd
-
-DESCRIPTION="Searchable online file/package database for Gentoo"
-HOMEPAGE="https://www.portagefilelist.de https://github.com/portagefilelist/client"
-SRC_URI="https://github.com/portagefilelist/client/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="+network-cron"
-
-RDEPEND="
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/termcolor[${PYTHON_USEDEP}]
- sys-apps/portage[${PYTHON_USEDEP}]
- network-cron? ( sys-apps/util-linux[caps] )
-"
-
-S="${WORKDIR}/client-${PV}"
-
-python_install_all() {
- if use network-cron ; then
- exeinto /etc/cron.weekly
- doexe cron/pfl
- fi
-
- systemd_dounit systemd/pfl.{service,timer}
-
- keepdir /var/lib/${PN}
-
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- if [[ ! -e "${EROOT}/var/lib/${PN}/pfl.info" ]]; then
- touch "${EROOT}/var/lib/${PN}/pfl.info" || die
- fi
- chown -R portage:portage "${EROOT}/var/lib/${PN}" || die
- chmod 775 "${EROOT}/var/lib/${PN}" || die
-}