summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/bash-completion/bash-completion-9999.ebuild')
-rw-r--r--app-shells/bash-completion/bash-completion-9999.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/app-shells/bash-completion/bash-completion-9999.ebuild b/app-shells/bash-completion/bash-completion-9999.ebuild
index 70ce84b4ed82..2f4caf5b89e1 100644
--- a/app-shells/bash-completion/bash-completion-9999.ebuild
+++ b/app-shells/bash-completion/bash-completion-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -99,7 +99,10 @@ src_prepare() {
src_test() {
# portage's HOME override breaks tests
- emake check HOME="$(egethome "${UID}")" PYTESTFLAGS="-vv" NETWORK=none
+ local myhome=$(unset HOME; echo ~)
+ local -x SANDBOX_PREDICT=${SANDBOX_PREDICT}
+ addpredict "${myhome}"
+ emake check HOME="${myhome}" PYTESTFLAGS="-vv" NETWORK=none
}
src_install() {