summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/bash/bash-4.4_p23-r2.ebuild')
-rw-r--r--app-shells/bash/bash-4.4_p23-r2.ebuild35
1 files changed, 21 insertions, 14 deletions
diff --git a/app-shells/bash/bash-4.4_p23-r2.ebuild b/app-shells/bash/bash-4.4_p23-r2.ebuild
index 3badc1359f27..d7671fb9e0cb 100644
--- a/app-shells/bash/bash-4.4_p23-r2.ebuild
+++ b/app-shells/bash/bash-4.4_p23-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit flag-o-matic toolchain-funcs multilib prefix
+inherit flag-o-matic toolchain-funcs prefix
# Official patchlevel
# See ftp://ftp.cwru.edu/pub/bash/bash-4.4-patches/
@@ -57,17 +57,19 @@ DEPEND="
RDEPEND="
${DEPEND}
"
-# we only need yacc when the .y files get patched (bash42-005)
+# We only need yacc when the .y files get patched (bash42-005)
#BDEPEND="virtual/yacc"
S="${WORKDIR}/${MY_P}"
pkg_setup() {
- if is-flag -malign-double ; then #7332
+ # bug #7332
+ if is-flag -malign-double ; then
eerror "Detected bad CFLAGS '-malign-double'. Do not use this"
eerror "as it breaks LFS (struct stat64) on x86."
die "remove -malign-double from your CFLAGS mr ricer"
fi
+
if use bashlogger ; then
ewarn "The logging patch should ONLY be used in restricted (i.e. honeypot) envs."
ewarn "This will log ALL output you enter into the shell, you have been warned."
@@ -82,8 +84,8 @@ src_prepare() {
# Include official patches
[[ ${PLEVEL} -gt 0 ]] && eapply -p0 $(patches -s)
- eapply "${FILESDIR}/${PN}-4.4-jobs_overflow.patch" #644720
- eapply "${FILESDIR}/${PN}-4.4-set-SHOBJ_STATUS.patch" #644720
+ eapply "${FILESDIR}/${PN}-4.4-jobs_overflow.patch" # bug #644720
+ eapply "${FILESDIR}/${PN}-4.4-set-SHOBJ_STATUS.patch" # bug #644720
# Clean out local libs so we know we use system ones w/releases.
if is_release ; then
@@ -95,7 +97,7 @@ src_prepare() {
# Prefixify hardcoded path names. No-op for non-prefix.
hprefixify pathnames.h.in
- # Avoid regenerating docs after patches #407985
+ # Avoid regenerating docs after patches, bug #407985
sed -i -r '/^(HS|RL)USER/s:=.*:=:' doc/Makefile.in || die
touch -r . doc/* || die
@@ -105,7 +107,13 @@ src_prepare() {
src_configure() {
local myconf=(
--disable-profiling
+
+ # Force linking with system curses ... the bundled termcap lib
+ # sucks bad compared to ncurses. For the most part, ncurses
+ # is here because readline needs it. But bash itself calls
+ # ncurses in one or two small places :(.
--with-curses
+
$(use_enable mem-scramble)
$(use_enable net net-redirections)
$(use_enable readline)
@@ -127,7 +135,7 @@ src_configure() {
$(use bashlogger && echo -DSYSLOG_HISTORY)
# Don't even think about building this statically without
- # reading Bug 7714 first. If you still build it statically,
+ # reading bug #7714 first. If you still build it statically,
# don't come crying to us with bugs ;).
#use static && export LDFLAGS="${LDFLAGS} -static"
use nls || myconf+=( --disable-nls )
@@ -141,28 +149,27 @@ src_configure() {
# is at least what's in the DEPEND up above.
export ac_cv_rl_version=${READLINE_VER%%_*}
- # Force linking with system curses ... the bundled termcap lib
- # sucks bad compared to ncurses. For the most part, ncurses
- # is here because readline needs it. But bash itself calls
- # ncurses in one or two small places :(.
-
if is_release ; then
# Use system readline only with released versions.
myconf+=( --with-installed-readline=. )
fi
- if use plugins; then
+ if use plugins ; then
append-ldflags -Wl,-rpath,/usr/$(get_libdir)/bash
else
# Disable the plugins logic by hand since bash doesn't
# provide a way of doing it.
export ac_cv_func_dl{close,open,sym}=no \
ac_cv_lib_dl_dlopen=no ac_cv_header_dlfcn_h=no
+
sed -i \
-e '/LOCAL_LDFLAGS=/s:-rdynamic::' \
configure || die
fi
- tc-export AR #444070
+
+ # bug #444070
+ tc-export AR
+
econf "${myconf[@]}"
}