summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/bash/bash-5.1_rc3.ebuild')
-rw-r--r--app-shells/bash/bash-5.1_rc3.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/app-shells/bash/bash-5.1_rc3.ebuild b/app-shells/bash/bash-5.1_rc3.ebuild
index 0c6c61907b2c..e8efbe608c08 100644
--- a/app-shells/bash/bash-5.1_rc3.ebuild
+++ b/app-shells/bash/bash-5.1_rc3.ebuild
@@ -247,7 +247,7 @@ pkg_preinst() {
# rewrite the symlink to ensure that its mtime changes. having /bin/sh
# missing even temporarily causes a fatal error with paludis.
local target=$(readlink "${EROOT}"/bin/sh)
- local tmp=$(emktemp "${EROOT}"/bin)
+ local tmp="${T}"/sh
ln -sf "${target}" "${tmp}"
mv -f "${tmp}" "${EROOT}"/bin/sh
fi