summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/bash/bash-5.2_p15.ebuild')
-rw-r--r--app-shells/bash/bash-5.2_p15.ebuild2
1 files changed, 2 insertions, 0 deletions
diff --git a/app-shells/bash/bash-5.2_p15.ebuild b/app-shells/bash/bash-5.2_p15.ebuild
index 3aa6795a6431..e0c1c5ecc52e 100644
--- a/app-shells/bash/bash-5.2_p15.ebuild
+++ b/app-shells/bash/bash-5.2_p15.ebuild
@@ -246,6 +246,8 @@ src_compile() {
emake CFLAGS="${CFLAGS} -fprofile-generate=${T}/pgo -fprofile-dir=${T}/pgo" -k check
+ tc-is-clang && llvm-profdata merge "${T}"/pgo --output="${T}"/pgo/default.profdata || die
+
# Rebuild Bash using the profiling data we just generated.
emake clean
emake CFLAGS="${CFLAGS} -fprofile-use=${T}/pgo -fprofile-dir=${T}/pgo"