summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/bash/files/bash-5.2_p21-configure-strtold.patch')
-rw-r--r--app-shells/bash/files/bash-5.2_p21-configure-strtold.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-shells/bash/files/bash-5.2_p21-configure-strtold.patch b/app-shells/bash/files/bash-5.2_p21-configure-strtold.patch
new file mode 100644
index 000000000000..51e9a19daebb
--- /dev/null
+++ b/app-shells/bash/files/bash-5.2_p21-configure-strtold.patch
@@ -0,0 +1,32 @@
+https://src.fedoraproject.org/rpms/bash/blob/bd5ac20b134f2936c54245fc83a8e70207d3e07e/f/bash-configure-c99-2.patch
+
+Another C compatibility issue: char ** and char * are distinct types,
+and strtold expects the former for its second argument.
+
+Submitted upstream:
+
+ <https://lists.gnu.org/archive/html/bug-bash/2023-11/msg00104.html>
+
+--- configure.ac
++++ configure.ac
+@@ -885,7 +885,7 @@ AC_CHECK_DECLS([strtold], [
+ [AC_COMPILE_IFELSE(
+ [AC_LANG_PROGRAM(
+ [[#include <stdlib.h>]],
+- [[long double r; char *foo, bar; r = strtold(foo, &bar);]]
++ [[long double r; char *foo, *bar; r = strtold(foo, &bar);]]
+ )],
+ [bash_cv_strtold_broken=no],[bash_cv_strtold_broken=yes])
+ ]
+
+--- configure
++++ configure
+@@ -15676,7 +15676,7 @@ else $as_nop
+ int
+ main (void)
+ {
+-long double r; char *foo, bar; r = strtold(foo, &bar);
++long double r; char *foo, *bar; r = strtold(foo, &bar);
+
+ ;
+ return 0;