summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/thefuck/thefuck-3.15.ebuild')
-rw-r--r--app-shells/thefuck/thefuck-3.15.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/app-shells/thefuck/thefuck-3.15.ebuild b/app-shells/thefuck/thefuck-3.15.ebuild
deleted file mode 100644
index 906bf65fd17f..000000000000
--- a/app-shells/thefuck/thefuck-3.15.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=(python{2_7,3_4,3_5})
-
-inherit distutils-r1
-
-DESCRIPTION="Magnificent app which corrects your previous console command"
-HOMEPAGE="https://github.com/nvbn/thefuck"
-SRC_URI="https://github.com/nvbn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="~amd64 ~x86"
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="test"
-
-RDEPEND="dev-python/psutil[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/decorator[${PYTHON_USEDEP}]
- dev-python/colorama[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' python2_7)"
-DEPEND="test? ( ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}] )
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-src_prepare() {
- sed -i -e "/import pip/s/^/#/" -e "/pip.__version__/,+3 s/^/#/" setup.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- py.test || die
-}