summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/posh-z/Manifest1
-rw-r--r--app-shells/posh-z/metadata.xml13
-rw-r--r--app-shells/posh-z/posh-z-1.1.12_p20230811.ebuild43
3 files changed, 57 insertions, 0 deletions
diff --git a/app-shells/posh-z/Manifest b/app-shells/posh-z/Manifest
new file mode 100644
index 000000000000..eb10bef7dd4d
--- /dev/null
+++ b/app-shells/posh-z/Manifest
@@ -0,0 +1 @@
+DIST posh-z-1.1.12_p20230811.tar.gz 290155 BLAKE2B 227d14c947daf121d013e4ad020a80935c87fd198e57e486d0f3598ef9c7d72d660e61b9576fecc6635226a47388d2eb9ea785762436fd177a74eeb867ad4095 SHA512 91d2173205ef5d27e9385ed5a09e6809be284488e69e4d6ca85019cdf0abfac26aaa01765c52eaee85aacd367982510bad5b3881ca3679f2e8ba19101db3cd50
diff --git a/app-shells/posh-z/metadata.xml b/app-shells/posh-z/metadata.xml
new file mode 100644
index 000000000000..b3ffc98a0269
--- /dev/null
+++ b/app-shells/posh-z/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>dotnet@gentoo.org</email>
+ <name>Gentoo Dotnet Project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://gitlab.com/badmotorfinger/z/issues/</bugs-to>
+ <remote-id type="github">badmotorfinger/z</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-shells/posh-z/posh-z-1.1.12_p20230811.ebuild b/app-shells/posh-z/posh-z-1.1.12_p20230811.ebuild
new file mode 100644
index 000000000000..9992bd48a310
--- /dev/null
+++ b/app-shells/posh-z/posh-z-1.1.12_p20230811.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Quickly navigate the file system based on your cd history"
+HOMEPAGE="https://github.com/badmotorfinger/z/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/badmotorfinger/z.git"
+else
+ if [[ "${PV}" == *_p20230811 ]] ; then
+ COMMIT="ca1c8d9f004eede2ba907da199bde542d9eff344"
+
+ SRC_URI="https://github.com/badmotorfinger/z/archive/${COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/z-${COMMIT}"
+ else
+ SRC_URI="https://github.com/badmotorfinger/z/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/z-${PV}"
+ fi
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="public-domain"
+SLOT="${PV%%_p*}"
+
+RDEPEND="virtual/pwsh:*"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ insinto "/usr/share/GentooPowerShell/Modules/z/${SLOT}"
+ doins z.*
+
+ einstalldocs
+}