summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/a2ps')
-rw-r--r--app-text/a2ps/a2ps-4.14-r7.ebuild4
-rw-r--r--app-text/a2ps/a2ps-4.14-r8.ebuild59
-rw-r--r--app-text/a2ps/files/a2ps-4.13-manpage-chmod.patch4
-rw-r--r--app-text/a2ps/files/a2ps-4.13c-emacs.patch3
-rw-r--r--app-text/a2ps/files/a2ps-4.13c-fnmatch-replacement.patch4
-rw-r--r--app-text/a2ps/files/a2ps-4.14-check-mempcpy.patch3
-rw-r--r--app-text/a2ps/files/a2ps-4.14-fix-stpcpy-proto.patch15
-rw-r--r--app-text/a2ps/files/a2ps-4.14-psset.patch3
-rw-r--r--app-text/a2ps/files/a2ps-4.14-ptrdiff_t.patch4
-rw-r--r--app-text/a2ps/files/a2ps-4.14-stdout.patch (renamed from app-text/a2ps/files/a2ps-4.13-stdout.diff)8
-rw-r--r--app-text/a2ps/files/a2ps-4.14-texinfo-5.x.patch3
11 files changed, 50 insertions, 60 deletions
diff --git a/app-text/a2ps/a2ps-4.14-r7.ebuild b/app-text/a2ps/a2ps-4.14-r7.ebuild
index 5beff0baee31..786c6a6aa41d 100644
--- a/app-text/a2ps/a2ps-4.14-r7.ebuild
+++ b/app-text/a2ps/a2ps-4.14-r7.ebuild
@@ -37,7 +37,7 @@ src_prepare() {
default
eapply "${FILESDIR}"/${PN}-4.13c-locale-gentoo.diff
- use vanilla || eapply -p0 "${FILESDIR}"/${PN}-4.13-stdout.diff
+ use vanilla || eapply "${FILESDIR}"/${P}-stdout.patch
if use cjk; then
eapply "${WORKDIR}"/${P}-ja_nls.patch
# bug #335803
@@ -62,7 +62,7 @@ src_prepare() {
eapply "${FILESDIR}"/${P}-check-mempcpy.patch
# fix compilation error due to invalid stpcpy() prototype, bug 216588
- eapply -p0 "${FILESDIR}"/${P}-fix-stpcpy-proto.patch
+ eapply "${FILESDIR}"/${P}-fix-stpcpy-proto.patch
# fix compilation error due to obstack.h issue, bug 269638
eapply "${FILESDIR}"/${P}-ptrdiff_t.patch
diff --git a/app-text/a2ps/a2ps-4.14-r8.ebuild b/app-text/a2ps/a2ps-4.14-r8.ebuild
index 3424f0792726..ede532a155af 100644
--- a/app-text/a2ps/a2ps-4.14-r8.ebuild
+++ b/app-text/a2ps/a2ps-4.14-r8.ebuild
@@ -33,11 +33,27 @@ BDEPEND=">=dev-util/gperf-2.7.2
SITEFILE="50${PN}-gentoo.el"
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.13c-locale-gentoo.diff
+ "${FILESDIR}"/${PN}-4.13c-fnmatch-replacement.patch
+ "${FILESDIR}"/${P}-psset.patch
+ "${FILESDIR}"/${PN}-4.13c-emacs.patch
+ "${FILESDIR}"/${PN}-4.13-manpage-chmod.patch
+ "${FILESDIR}"/${P}-check-mempcpy.patch
+ "${FILESDIR}"/${P}-fix-stpcpy-proto.patch
+ "${FILESDIR}"/${P}-ptrdiff_t.patch
+ "${FILESDIR}"/${P}-texinfo-5.x.patch
+ "${FILESDIR}"/${P}-CVE-2014-0466.patch
+ "${FILESDIR}"/${P}-CVE-2001-1593.patch
+ "${FILESDIR}"/${P}-texinfo-6.7-encoding.patch
+ "${FILESDIR}"/${P}-function-decl.patch
+ "${FILESDIR}"/${P}-configure.ac.patch
+)
+
src_prepare() {
default
- eapply "${FILESDIR}"/${PN}-4.13c-locale-gentoo.diff
- use vanilla || eapply -p0 "${FILESDIR}"/${PN}-4.13-stdout.diff
+ use vanilla || eapply "${FILESDIR}"/${P}-stdout.patch
if use cjk; then
eapply "${WORKDIR}"/${P}-ja_nls.patch
# bug #335803
@@ -46,45 +62,6 @@ src_prepare() {
eapply "${FILESDIR}"/${P}-cleanup.patch
fi
- # fix fnmatch replacement, bug #134546
- eapply "${FILESDIR}"/${PN}-4.13c-fnmatch-replacement.patch
-
- # bug #122026
- eapply "${FILESDIR}"/${P}-psset.patch
-
- # fix emacs printing, bug #114627
- eapply "${FILESDIR}"/a2ps-4.13c-emacs.patch
-
- # fix chmod error, #167670
- eapply "${FILESDIR}"/a2ps-4.13-manpage-chmod.patch
-
- # add configure check for mempcpy, bug 216588
- eapply "${FILESDIR}"/${P}-check-mempcpy.patch
-
- # fix compilation error due to invalid stpcpy() prototype, bug 216588
- eapply -p0 "${FILESDIR}"/${P}-fix-stpcpy-proto.patch
-
- # fix compilation error due to obstack.h issue, bug 269638
- eapply "${FILESDIR}"/${P}-ptrdiff_t.patch
-
- # fix compilation error due to texinfo 5.x, bug 482748
- eapply "${FILESDIR}"/${P}-texinfo-5.x.patch
-
- # fix CVE-2014-0466, bug 506352
- eapply "${FILESDIR}"/${P}-CVE-2014-0466.patch
-
- # fix CVE-2001-1593, bug 507024
- eapply "${FILESDIR}"/${P}-CVE-2001-1593.patch
-
- # specify encoding explicitly, bug #695918
- eapply "${FILESDIR}"/${P}-texinfo-6.7-encoding.patch
-
- # fix function declaration, bug 870763
- eapply "${FILESDIR}"/${P}-function-decl.patch
-
- # update reference in man/Makefile.maint
- eapply "${FILESDIR}"/${P}-configure.ac.patch
-
# fix building with sys-devel/automake >= 1.12, bug 420503
rm -f {.,ogonkify}/aclocal.m4 || die
sed -i \
diff --git a/app-text/a2ps/files/a2ps-4.13-manpage-chmod.patch b/app-text/a2ps/files/a2ps-4.13-manpage-chmod.patch
index e0c61124e9df..8e8454a3ea48 100644
--- a/app-text/a2ps/files/a2ps-4.13-manpage-chmod.patch
+++ b/app-text/a2ps/files/a2ps-4.13-manpage-chmod.patch
@@ -1,4 +1,6 @@
-diff -ur a2ps-4.13.orig/man/Makefile.maint a2ps-4.13/man/Makefile.maint
+fix chmod error
+https://bugs.gentoo.org/167670
+
--- a2ps-4.13.orig/man/Makefile.maint 2002-03-04 20:46:26.000000000 +0200
+++ a2ps-4.13/man/Makefile.maint 2007-02-19 21:50:29.000000000 +0200
@@ -20,7 +20,7 @@
diff --git a/app-text/a2ps/files/a2ps-4.13c-emacs.patch b/app-text/a2ps/files/a2ps-4.13c-emacs.patch
index f1cd5d9ebdfc..97099a7393d9 100644
--- a/app-text/a2ps/files/a2ps-4.13c-emacs.patch
+++ b/app-text/a2ps/files/a2ps-4.13c-emacs.patch
@@ -1,3 +1,6 @@
+fix emacs printing
+https://bugs.gentoo.org/114627
+
--- a2ps-4.13/contrib/emacs/a2ps-print.el.orig 2005-12-05 08:03:48.000000000 +0100
+++ a2ps-4.13/contrib/emacs/a2ps-print.el 2005-12-06 16:38:14.000000000 +0100
@@ -93,6 +93,7 @@
diff --git a/app-text/a2ps/files/a2ps-4.13c-fnmatch-replacement.patch b/app-text/a2ps/files/a2ps-4.13c-fnmatch-replacement.patch
index c49ab78c93c0..92098541b694 100644
--- a/app-text/a2ps/files/a2ps-4.13c-fnmatch-replacement.patch
+++ b/app-text/a2ps/files/a2ps-4.13c-fnmatch-replacement.patch
@@ -1,4 +1,6 @@
-diff -Naurp a2ps-4.13.orig/lib/fnmatch.c a2ps-4.13/lib/fnmatch.c
+fix fnmatch replacement
+https://bugs.gentoo.org/134546
+
--- a2ps-4.13.orig/lib/fnmatch.c 2002-03-04 12:46:25 -0600
+++ a2ps-4.13/lib/fnmatch.c 2006-05-27 11:41:15 -0500
@@ -27,18 +27,6 @@
diff --git a/app-text/a2ps/files/a2ps-4.14-check-mempcpy.patch b/app-text/a2ps/files/a2ps-4.14-check-mempcpy.patch
index 7b820cead05f..62a8ab21961f 100644
--- a/app-text/a2ps/files/a2ps-4.14-check-mempcpy.patch
+++ b/app-text/a2ps/files/a2ps-4.14-check-mempcpy.patch
@@ -1,3 +1,6 @@
+add configure check for mempcpy
+https://bugs.gentoo.org/216588
+
--- a2ps-4.14-orig/configure.in 2008-04-16 08:36:03.000000000 +0200
+++ a2ps-4.14/configure.in 2008-04-16 08:36:29.000000000 +0200
@@ -137,7 +137,8 @@
diff --git a/app-text/a2ps/files/a2ps-4.14-fix-stpcpy-proto.patch b/app-text/a2ps/files/a2ps-4.14-fix-stpcpy-proto.patch
index 7c3c69076ae9..ed72bbad0715 100644
--- a/app-text/a2ps/files/a2ps-4.14-fix-stpcpy-proto.patch
+++ b/app-text/a2ps/files/a2ps-4.14-fix-stpcpy-proto.patch
@@ -1,9 +1,9 @@
-=== modified file 'lib/xstrrpl.c'
---- lib/xstrrpl.c 2008-04-14 18:04:50 +0000
-+++ lib/xstrrpl.c 2008-04-14 18:20:20 +0000
-@@ -20,12 +20,10 @@
-
- #include "system.h"
+fix compilation error due to invalid stpcpy() prototype
+https://bugs.gentoo.org/216588
+
+--- a2ps-4.14/lib/xstrrpl.c
++++ a2ps-4.14/lib/xstrrpl.c
+@@ -22,8 +22,6 @@
#include <assert.h>
#include "xstrrpl.h"
@@ -12,6 +12,3 @@
/* Perform subsitutions in string. Result is malloc'd
E.g., result = xstrrrpl ("1234", subst) gives result = "112333"
where subst = { {"1", "11"}, {"3", "333"}, { "4", ""}}
- */
- char *
-
diff --git a/app-text/a2ps/files/a2ps-4.14-psset.patch b/app-text/a2ps/files/a2ps-4.14-psset.patch
index 291c3aac4fa4..e0793bc9eb1f 100644
--- a/app-text/a2ps/files/a2ps-4.14-psset.patch
+++ b/app-text/a2ps/files/a2ps-4.14-psset.patch
@@ -1,4 +1,5 @@
-diff -Naur a2ps-4.14.orig/contrib/psset.in a2ps-4.14/contrib/psset.in
+https://bugs.gentoo.org/122026
+
--- a2ps-4.14.orig/contrib/psset.in 2007-12-29 12:29:01.000000000 +0900
+++ a2ps-4.14/contrib/psset.in 2009-04-12 12:17:43.000000000 +0900
@@ -219,7 +219,7 @@
diff --git a/app-text/a2ps/files/a2ps-4.14-ptrdiff_t.patch b/app-text/a2ps/files/a2ps-4.14-ptrdiff_t.patch
index 00d955a819a9..7ff45cf3bc4a 100644
--- a/app-text/a2ps/files/a2ps-4.14-ptrdiff_t.patch
+++ b/app-text/a2ps/files/a2ps-4.14-ptrdiff_t.patch
@@ -1,4 +1,6 @@
-diff -uNr a2ps-4.14/lib/obstack.h a2ps-4.14.test/lib/obstack.h
+fix compilation error due to obstack.h issue
+https://bugs.gentoo.org/269638
+
--- a2ps-4.14/lib/obstack.h 2007-12-29 09:37:59.000000000 +0800
+++ a2ps-4.14.test/lib/obstack.h 2009-06-10 18:49:45.000000000 +0900
@@ -138,9 +138,9 @@
diff --git a/app-text/a2ps/files/a2ps-4.13-stdout.diff b/app-text/a2ps/files/a2ps-4.14-stdout.patch
index 1e40e618fcbd..6661b0e26f03 100644
--- a/app-text/a2ps/files/a2ps-4.13-stdout.diff
+++ b/app-text/a2ps/files/a2ps-4.14-stdout.patch
@@ -1,8 +1,8 @@
---- lib/printers.c.orig Tue Oct 12 00:01:59 1999
-+++ lib/printers.c Wed May 2 11:23:25 2001
+--- a2ps-4.14/lib/printers.c
++++ a2ps-4.14/lib/printers.c
@@ -315,8 +315,8 @@
- res->ppd = NULL; /* Printer's ppd are not read yet */
-
+ res->ppd = NULL; /* Printer's ppd are not read yet */
+
/* Output */
- /* Default is to send to default printer */
- res->flag_output_is_printer = true;
diff --git a/app-text/a2ps/files/a2ps-4.14-texinfo-5.x.patch b/app-text/a2ps/files/a2ps-4.14-texinfo-5.x.patch
index 44cd4bfd099d..baf53cfcc122 100644
--- a/app-text/a2ps/files/a2ps-4.14-texinfo-5.x.patch
+++ b/app-text/a2ps/files/a2ps-4.14-texinfo-5.x.patch
@@ -1,3 +1,6 @@
+fix compilation error due to texinfo 5.x
+https://bugs.gentoo.org/482748
+
--- a2ps-4.14/doc/a2ps.texi.bero 2013-03-26 10:31:31.230137555 +0100
+++ a2ps-4.14/doc/a2ps.texi 2013-03-26 11:01:01.504006086 +0100
@@ -44,10 +44,6 @@