summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/agrep/agrep-2.04.ebuild')
-rw-r--r--app-text/agrep/agrep-2.04.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-text/agrep/agrep-2.04.ebuild b/app-text/agrep/agrep-2.04.ebuild
new file mode 100644
index 000000000000..f7bc2f671725
--- /dev/null
+++ b/app-text/agrep/agrep-2.04.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="agrep is a tool for the fast searching of text allowing for errors in the search pattern"
+HOMEPAGE="ftp://ftp.cs.arizona.edu/agrep/README"
+SRC_URI="ftp://ftp.cs.arizona.edu/agrep/${P}.tar.Z"
+
+LICENSE="AGREP"
+SLOT="0"
+KEYWORDS="amd64 ~mips ppc ppc64 sparc x86 ~ppc-macos ~sparc-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ !dev-libs/tre
+ !app-misc/glimpse"
+
+src_compile() {
+ # Remove first occurace of CFLAGS so we grab the user CFLAGS
+ sed -i -e 's/^CFLAGS.*//' Makefile || die
+ tc-export CC
+ emake || die
+}
+
+src_install() {
+ dobin agrep || die
+ doman agrep.1 || die
+ dodoc README agrep.algorithms agrep.chronicle COPYRIGHT \
+ contribution.list || die
+}