summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/dblatex/dblatex-0.3.12.ebuild')
-rw-r--r--app-text/dblatex/dblatex-0.3.12.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/app-text/dblatex/dblatex-0.3.12.ebuild b/app-text/dblatex/dblatex-0.3.12.ebuild
deleted file mode 100644
index bf46b5ae0c83..000000000000
--- a/app-text/dblatex/dblatex-0.3.12.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Transform DocBook using TeX macros"
-HOMEPAGE="http://dblatex.sourceforge.net/"
-SRC_URI="https://downloads.sourceforge.net/project/dblatex/dblatex/${P}/${PN}3-${PV}.tar.bz2"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="inkscape"
-
-RDEPEND="
- app-text/docbook-xml-dtd:4.5
- dev-libs/kpathsea
- dev-libs/libxslt
- dev-libs/libxslt
- dev-texlive/texlive-fontutils
- dev-texlive/texlive-latex
- dev-texlive/texlive-latexextra
- dev-texlive/texlive-latexrecommended
- dev-texlive/texlive-mathscience
- dev-texlive/texlive-pictures
- dev-texlive/texlive-xetex
- gnome-base/librsvg
- media-gfx/imagemagick
- media-gfx/transfig
- inkscape? ( media-gfx/inkscape )
-"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${PN}3-${PV}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.3.11-path-logging.patch"
- "${FILESDIR}/${PN}-0.3.11-setup.patch"
- "${FILESDIR}/${PN}-0.3.11-encode.patch"
-)
-
-python_prepare_all() {
- # Manual page is precomressed, but we will use our own compression later.
- gunzip docs/manpage/dblatex.1.gz || die
- # If we dont have inkscape we need to use an alternative SVG converter
- use inkscape || eapply "${FILESDIR}/${PN}-0.3.11-no-inkscape-dependency.patch"
- # If we use inscape however we want to make dblatex compatible with v1.0
- use inkscape && eapply "${FILESDIR}/${PN}-0.3.11-inkscape-1.0.patch"
- distutils-r1_python_prepare_all
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- # Move package documentation to a folder name containing version number
- mv "${D}"/usr/share/doc/${PN} "${D}"/usr/share/doc/${PF} || die
-}