summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/diff-pdf/diff-pdf-0.4.1-r2.ebuild')
-rw-r--r--app-text/diff-pdf/diff-pdf-0.4.1-r2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-text/diff-pdf/diff-pdf-0.4.1-r2.ebuild b/app-text/diff-pdf/diff-pdf-0.4.1-r2.ebuild
new file mode 100644
index 000000000000..992e9b377978
--- /dev/null
+++ b/app-text/diff-pdf/diff-pdf-0.4.1-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# No EAPI=7 support in wxwidgets.eclass.
+EAPI=7
+
+inherit autotools wxwidgets
+
+DESCRIPTION="A simple tool for visually comparing two PDF files"
+HOMEPAGE="http://vslavik.github.io/diff-pdf/ https://github.com/vslavik/diff-pdf/"
+SRC_URI="https://github.com/vslavik/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+# The COPYING.icons file states that two icons were taken from
+# version 2.16.5 of GTK+, which is licensed LGPL-2+.
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+# The build system checks for "poppler-glib", which is provided only
+# when app-text/poppler is built with USE=cairo. Moreover the glib ABI
+# of poppler is relatively stable, and I can only assume that diff-pdf
+# uses that rather than the low-level libpoppler.so API. Since the
+# subslot on app-text/poppler is ONLY for the low-level API, we
+# therefore don't need a subslot dependency on app-text/poppler.
+#
+# Since diff-pdf.cpp includes glib.h directly, I've included
+# dev-libs/glib as an explicit dependency. Ditto for x11-libs/cairo.
+DEPEND="app-text/poppler[cairo]
+ dev-libs/glib
+ x11-libs/cairo
+ x11-libs/wxGTK:3.0-gtk3[X]"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-no-poppler-cairo-check.patch" )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ WX_GTK_VER="3.0-gtk3"
+ setup-wxwidgets
+ default
+}