summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/expander')
-rw-r--r--app-text/expander/expander-2.05-r3.ebuild (renamed from app-text/expander/expander-2.0.5-r2.ebuild)20
-rw-r--r--app-text/expander/files/expander-2.05-clang15.patch60
-rw-r--r--app-text/expander/files/expander-2.05-gentoo.patch (renamed from app-text/expander/files/expander-2.0.5-gentoo.patch)0
-rw-r--r--app-text/expander/metadata.xml2
4 files changed, 72 insertions, 10 deletions
diff --git a/app-text/expander/expander-2.0.5-r2.ebuild b/app-text/expander/expander-2.05-r3.ebuild
index c1ddd2ee423e..ee8a110a01e6 100644
--- a/app-text/expander/expander-2.0.5-r2.ebuild
+++ b/app-text/expander/expander-2.05-r3.ebuild
@@ -1,24 +1,26 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit toolchain-funcs
DESCRIPTION="Expander is a utility that acts as a filter for text editors"
HOMEPAGE="http://www.nedit.org"
-SRC_URI="ftp://ftp.nedit.org/pub/contrib/misc/nedit_expander_kit_2.05.tar.gz"
+SRC_URI="ftp://ftp.nedit.org/pub/contrib/misc/nedit_expander_kit_${PV}.tar.gz"
+S="${WORKDIR}"/${PN}
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~x86-linux ~ppc-macos"
-S="${WORKDIR}/${PN}"
-
-PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-clang15.patch
+)
src_compile() {
- emake -C src CC=$(tc-getCC)
+ emake -C src CC="$(tc-getCC)"
}
src_install() {
@@ -35,7 +37,7 @@ src_install() {
pkg_postinst() {
elog
- elog "Instructions for using expander with NEdit are in /usr/share/doc/${PF}/INSTALL"
- elog "Macro, definition and template files can be found in /usr/share/${P}"
+ elog "Instructions for using expander with NEdit are in ${EROOT}/usr/share/doc/${PF}/INSTALL"
+ elog "Macro, definition and template files can be found in ${EROOT}/usr/share/${P}"
elog
}
diff --git a/app-text/expander/files/expander-2.05-clang15.patch b/app-text/expander/files/expander-2.05-clang15.patch
new file mode 100644
index 000000000000..a7ae9bed3ddf
--- /dev/null
+++ b/app-text/expander/files/expander-2.05-clang15.patch
@@ -0,0 +1,60 @@
+https://bugs.gentoo.org/870898
+--- a/src/align_columns.c
++++ b/src/align_columns.c
+@@ -28,6 +28,7 @@
+ #include <string.h>
+ #include <stdlib.h>
+ #include <ctype.h>
++#include <unistd.h>
+
+ /*============================================================================*/
+ /* SYMBOL DEFINITIONS */
+--- a/src/align_comments.c
++++ b/src/align_comments.c
+@@ -28,6 +28,7 @@
+ #include <string.h>
+ #include <stdlib.h>
+ #include <ctype.h>
++#include <unistd.h>
+
+ /*===========================================================================*/
+ /* SYMBOL DEFINITIONS */
+--- a/src/boxcomment.c
++++ b/src/boxcomment.c
+@@ -59,6 +59,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <stdlib.h>
++#include <unistd.h>
+
+ /*============================================================================*/
+ /* SYMBOL DEFINITIONS */
+--- a/src/expander.c
++++ b/src/expander.c
+@@ -114,6 +114,7 @@
+ #include <string.h>
+ #include <time.h>
+ #include <ctype.h>
++#include <unistd.h>
+
+ /*==========================================================================*/
+ /* MACRO DEFINITIONS */
+@@ -1264,7 +1265,7 @@ bool_t locate_definition(
+ bool_t ignore_definition = FALSE;
+ int i;
+ char line[ MAXBUF ];
+- static level = 0;
++ static int level = 0;
+
+ /*---------------------
+ * Recursion protection.
+--- a/src/where_is.c
++++ b/src/where_is.c
+@@ -54,6 +54,7 @@
+ #include <stdlib.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
++#include <unistd.h>
+
+ typedef int bool_t;
+
diff --git a/app-text/expander/files/expander-2.0.5-gentoo.patch b/app-text/expander/files/expander-2.05-gentoo.patch
index 460a8164cee5..460a8164cee5 100644
--- a/app-text/expander/files/expander-2.0.5-gentoo.patch
+++ b/app-text/expander/files/expander-2.05-gentoo.patch
diff --git a/app-text/expander/metadata.xml b/app-text/expander/metadata.xml
index 6f49eba8f496..85e4ed814fa2 100644
--- a/app-text/expander/metadata.xml
+++ b/app-text/expander/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<!-- maintainer-needed -->
</pkgmetadata>