summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/feathernotes')
-rw-r--r--app-text/feathernotes/Manifest1
-rw-r--r--app-text/feathernotes/feathernotes-1.2.0.ebuild35
-rw-r--r--app-text/feathernotes/feathernotes-9999.ebuild33
-rw-r--r--app-text/feathernotes/metadata.xml17
4 files changed, 86 insertions, 0 deletions
diff --git a/app-text/feathernotes/Manifest b/app-text/feathernotes/Manifest
new file mode 100644
index 000000000000..e7f3dcef6859
--- /dev/null
+++ b/app-text/feathernotes/Manifest
@@ -0,0 +1 @@
+DIST feathernotes-1.2.0.tar.gz 926273 BLAKE2B ae945ae6adb95d3cd8ef42becfcd68a591ef62f97f05d514f19a9c07e6900b2230e89361b65abfc2082797755bcb8b6c521b72a6406a21886ba6ab386f23295f SHA512 f6aabc0d4bee5f3af20a86035befbc27eddedc5ec37c9a353723a80fb0f691af6ad57d5f50a0e8504336c141822227f8287ed61e52d084b34e3b8ab5246315c0
diff --git a/app-text/feathernotes/feathernotes-1.2.0.ebuild b/app-text/feathernotes/feathernotes-1.2.0.ebuild
new file mode 100644
index 000000000000..3f3075fd6e7a
--- /dev/null
+++ b/app-text/feathernotes/feathernotes-1.2.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION=" Lightweight Qt Notes-Manager for Linux"
+HOMEPAGE="https://github.com/tsujan/FeatherNotes"
+SRC_URI="https://github.com/tsujan/FeatherNotes/archive/V${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/FeatherNotes-${PV}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="spell X"
+
+RDEPEND="
+ dev-qt/qtbase:6[dbus,gui,network,widgets,xml,X?]
+ dev-qt/qtsvg:6
+ spell? ( app-text/hunspell:= )
+ X? ( x11-libs/libX11 )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+"
+BDEPEND="dev-qt/qttools:6[linguist]"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITHOUT_X11=$(usex !X)
+ -DWITH_HUNSPELL=$(usex spell)
+ )
+ cmake_src_configure
+}
diff --git a/app-text/feathernotes/feathernotes-9999.ebuild b/app-text/feathernotes/feathernotes-9999.ebuild
new file mode 100644
index 000000000000..880fc704e847
--- /dev/null
+++ b/app-text/feathernotes/feathernotes-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit git-r3 cmake xdg
+
+DESCRIPTION=" Lightweight Qt Notes-Manager for Linux"
+HOMEPAGE="https://github.com/tsujan/FeatherNotes"
+EGIT_REPO_URI="https://github.com/tsujan/FeatherNotes"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="spell X"
+
+RDEPEND="
+ dev-qt/qtbase:6[dbus,gui,network,widgets,xml,X?]
+ dev-qt/qtsvg:6
+ spell? ( app-text/hunspell:= )
+ X? ( x11-libs/libX11 )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+"
+BDEPEND="dev-qt/qttools:6[linguist]"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITHOUT_X11=$(usex !X)
+ -DWITH_HUNSPELL=$(usex spell)
+ )
+ cmake_src_configure
+}
diff --git a/app-text/feathernotes/metadata.xml b/app-text/feathernotes/metadata.xml
new file mode 100644
index 000000000000..25af69d6ae8f
--- /dev/null
+++ b/app-text/feathernotes/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>arthurzam@gentoo.org</email>
+ <name>Arthur Zamarin</name>
+ </maintainer>
+ <use>
+ <flag name="X">
+ Link application against X11 libraries which adds
+ support for virtual desktop awareness and tab DND
+ </flag>
+ </use>
+ <upstream>
+ <remote-id type="github">tsujan/FeatherNotes</remote-id>
+ </upstream>
+</pkgmetadata>