summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/ghostscript-gpl')
-rw-r--r--app-text/ghostscript-gpl/ghostscript-gpl-9.15-r1.ebuild6
-rw-r--r--app-text/ghostscript-gpl/ghostscript-gpl-9.18.ebuild6
2 files changed, 10 insertions, 2 deletions
diff --git a/app-text/ghostscript-gpl/ghostscript-gpl-9.15-r1.ebuild b/app-text/ghostscript-gpl/ghostscript-gpl-9.15-r1.ebuild
index 84e590c8ae36..46321ba50eb7 100644
--- a/app-text/ghostscript-gpl/ghostscript-gpl-9.15-r1.ebuild
+++ b/app-text/ghostscript-gpl/ghostscript-gpl-9.15-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit autotools eutils multilib versionator flag-o-matic
+inherit autotools eutils multilib versionator flag-o-matic toolchain-funcs
DESCRIPTION="Ghostscript is an interpreter for the PostScript language and for PDF"
HOMEPAGE="http://ghostscript.com/"
@@ -143,11 +143,15 @@ src_configure() {
FONTPATH="$FONTPATH${FONTPATH:+:}$path"
done
+ # We force the endian configure flags until this is fixed:
+ # http://bugs.ghostscript.com/show_bug.cgi?id=696498
+ PKGCONFIG=$(type -P $(tc-getPKG_CONFIG)) \
econf \
--enable-dynamic \
--enable-freetype \
--enable-fontconfig \
--enable-openjpeg \
+ --enable-$(tc-endian)-endian \
--disable-compile-inits \
--with-drivers=ALL \
--with-fontpath="$FONTPATH" \
diff --git a/app-text/ghostscript-gpl/ghostscript-gpl-9.18.ebuild b/app-text/ghostscript-gpl/ghostscript-gpl-9.18.ebuild
index a9ba6bf30764..13e873ca3d53 100644
--- a/app-text/ghostscript-gpl/ghostscript-gpl-9.18.ebuild
+++ b/app-text/ghostscript-gpl/ghostscript-gpl-9.18.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit autotools eutils multilib versionator flag-o-matic
+inherit autotools eutils multilib versionator flag-o-matic toolchain-funcs
DESCRIPTION="Ghostscript is an interpreter for the PostScript language and for PDF"
HOMEPAGE="http://ghostscript.com/"
@@ -148,11 +148,15 @@ src_configure() {
FONTPATH="$FONTPATH${FONTPATH:+:}$path"
done
+ # We force the endian configure flags until this is fixed:
+ # http://bugs.ghostscript.com/show_bug.cgi?id=696498
+ PKGCONFIG=$(type -P $(tc-getPKG_CONFIG)) \
econf \
--enable-dynamic \
--enable-freetype \
--enable-fontconfig \
--enable-openjpeg \
+ --enable-$(tc-endian)-endian \
--disable-compile-inits \
--with-drivers=ALL \
--with-fontpath="$FONTPATH" \