summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/hnb/hnb-1.9.18-r1.ebuild')
-rw-r--r--app-text/hnb/hnb-1.9.18-r1.ebuild27
1 files changed, 15 insertions, 12 deletions
diff --git a/app-text/hnb/hnb-1.9.18-r1.ebuild b/app-text/hnb/hnb-1.9.18-r1.ebuild
index a38796bc73be..2c262725c22e 100644
--- a/app-text/hnb/hnb-1.9.18-r1.ebuild
+++ b/app-text/hnb/hnb-1.9.18-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils toolchain-funcs
+EAPI=7
+
+inherit toolchain-funcs
DESCRIPTION="A program to organize many kinds of data in one place"
HOMEPAGE="http://hnb.sourceforge.net/"
@@ -13,20 +14,22 @@ LICENSE="GPL-2"
KEYWORDS="amd64 ppc ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
RDEPEND="sys-libs/ncurses"
-DEPEND="
- ${RDEPEND}
- virtual/pkgconfig
-"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-flags.patch
+ "${FILESDIR}"/${P}-include.patch
+ "${FILESDIR}"/${P}-printf.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+)
src_prepare() {
+ default
+
rm -r ${P} || die
rm src/cli_history.o || die
- epatch \
- "${FILESDIR}"/${P}-flags.patch \
- "${FILESDIR}"/${P}-include.patch \
- "${FILESDIR}"/${P}-printf.patch
-
tc-export AR CC PKG_CONFIG
# bug #532552