summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/jabref-bin/jabref-bin-3.3.ebuild')
-rw-r--r--app-text/jabref-bin/jabref-bin-3.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-text/jabref-bin/jabref-bin-3.3.ebuild b/app-text/jabref-bin/jabref-bin-3.3.ebuild
new file mode 100644
index 000000000000..86add2dd9749
--- /dev/null
+++ b/app-text/jabref-bin/jabref-bin-3.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils java-pkg-2
+
+MY_PV_1="${PV/_beta/b}"
+MY_PV="${MY_PV_1/_rc/}"
+MY_URI_PV_1="${PV/rc/}"
+MY_URI_PV="${MY_URI_PV_1//_/%20}"
+
+DESCRIPTION="Java GUI for managing BibTeX and other bibliographies"
+HOMEPAGE="http://www.jabref.org/"
+SRC_URI="mirror://sourceforge/jabref/JabRef-${MY_PV}.jar"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="|| ( >=virtual/jre-1.8 >=virtual/jdk-1.8 )"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp -v "${DISTDIR}/${A}" . || die
+ jar xf ${A} images/icons/JabRef-icon-48.png || die
+}
+
+src_install() {
+ java-pkg_newjar "JabRef-${MY_PV}.jar"
+ java-pkg_dolauncher "${PN}" --jar "${PN}.jar"
+ newicon images/icons/JabRef-icon-48.png JabRef-bin-icon.png
+ make_desktop_entry "${PN}" JabRef-bin JabRef-bin-icon Office
+}