summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/libabw/libabw-0.0.2.ebuild')
-rw-r--r--app-text/libabw/libabw-0.0.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-text/libabw/libabw-0.0.2.ebuild b/app-text/libabw/libabw-0.0.2.ebuild
new file mode 100644
index 000000000000..b686567e2c59
--- /dev/null
+++ b/app-text/libabw/libabw-0.0.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit base eutils
+
+DESCRIPTION="Library parsing abiword documents"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/libabw/"
+SRC_URI="http://dev-www.libreoffice.org/src//${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc x86"
+IUSE="doc static-libs"
+
+RDEPEND="
+ app-text/libwpd:0.9
+ dev-libs/libxml2
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.46
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --disable-werror \
+ $(use_enable static-libs static) \
+ $(use_with doc docs)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}