summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/libmspub/libmspub-9999.ebuild')
-rw-r--r--app-text/libmspub/libmspub-9999.ebuild38
1 files changed, 20 insertions, 18 deletions
diff --git a/app-text/libmspub/libmspub-9999.ebuild b/app-text/libmspub/libmspub-9999.ebuild
index c627cd0bee6f..2035408ee17b 100644
--- a/app-text/libmspub/libmspub-9999.ebuild
+++ b/app-text/libmspub/libmspub-9999.ebuild
@@ -1,26 +1,28 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit flag-o-matic
-EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libmspub.git"
-[[ ${PV} == 9999 ]] && inherit autotools git-r3
-
+if [[ ${PV} = *9999 ]]; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libmspub.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://dev-www.libreoffice.org/src/libmspub/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
DESCRIPTION="Library parsing Microsoft Publisher documents"
HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libmspub"
-[[ ${PV} == 9999 ]] || SRC_URI="https://dev-www.libreoffice.org/src/libmspub/${P}.tar.xz"
LICENSE="LGPL-2.1"
SLOT="0"
-
-# Don't move KEYWORDS on the previous line or ekeyword won't work # 399061
-[[ ${PV} == 9999 ]] || \
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
-
IUSE="doc static-libs"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
RDEPEND="
dev-libs/icu:=
dev-libs/librevenge
@@ -29,27 +31,27 @@ RDEPEND="
DEPEND="${RDEPEND}
dev-libs/boost
sys-devel/libtool
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
"
src_prepare() {
default
[[ -d m4 ]] || mkdir "m4"
- [[ ${PV} == 9999 ]] && eautoreconf
+ [[ ${PV} == *9999 ]] && eautoreconf
}
src_configure() {
# bug 619044
append-cxxflags -std=c++14
- econf \
- --disable-werror \
- $(use_with doc docs) \
+ local myeconfargs=(
+ --disable-werror
+ $(use_with doc docs)
$(use_enable static-libs static)
+ )
+ econf "${myeconfargs[@]}"
}
src_install() {
default
- find "${D}" -name '*.la' -delete || die
+ find "${D}" -name '*.la' -type f -delete || die
}