summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/libmwaw')
-rw-r--r--app-text/libmwaw/Manifest3
-rw-r--r--app-text/libmwaw/libmwaw-0.3.19.ebuild52
-rw-r--r--app-text/libmwaw/libmwaw-0.3.22.ebuild (renamed from app-text/libmwaw/libmwaw-0.3.20.ebuild)18
-rw-r--r--app-text/libmwaw/libmwaw-9999.ebuild18
-rw-r--r--app-text/libmwaw/metadata.xml2
5 files changed, 24 insertions, 69 deletions
diff --git a/app-text/libmwaw/Manifest b/app-text/libmwaw/Manifest
index 1ff60daad3d0..e0a19edb5676 100644
--- a/app-text/libmwaw/Manifest
+++ b/app-text/libmwaw/Manifest
@@ -1,2 +1 @@
-DIST libmwaw-0.3.19.tar.xz 1401720 BLAKE2B 93e63993dd73d52d1b071c44a5efa4ba2495a370a767cd80fbeb437a56224d333781cfdf32c3ca1c0a3794544da6cdf8c967badf98b6858796fbc8f2ea7878c1 SHA512 a5b74f417366f7e8a8303948e678d54caf9c45e0b51694d39593926b2f2fbbaa5dfea5dee8a6b4a656e5ca5bd880f41a76e7b869f55230690740b7ab75a28f1f
-DIST libmwaw-0.3.20.tar.xz 1425812 BLAKE2B a708ce4a28a0d5a5a5ee9d178c67119189add0180e61d67af6821c509d95b9f8bfb60eeb1afcdf8e2da5bed26053108b12db57db98912d97dc7e0ef0f7121f18 SHA512 d6cd28629b6482dd61e070036e94568ecc44d9064dddd9c699c7362caa8ef36652ce84cf0f199813854636f2e39ab19d47f4e148990822791b88cd3f17f68b3b
+DIST libmwaw-0.3.22.tar.xz 1476620 BLAKE2B 8133dbd06fdde5caabe9284fd0535e97335385a96ceea4ea9bc1d6f2a28f14f22f6943d71ee6631cb8d67c8791b56ed3d928bb18c723c7aec0b8cf7faf8427d7 SHA512 8682e7006430764cb825cd0bf4822ff42ea3035606e13a804afb9fa3c6dc583f34ae24cea226c1d31eae95224525289801c0afa3853adc6ab396bb9df34a60b4
diff --git a/app-text/libmwaw/libmwaw-0.3.19.ebuild b/app-text/libmwaw/libmwaw-0.3.19.ebuild
deleted file mode 100644
index 4f07691b3c39..000000000000
--- a/app-text/libmwaw/libmwaw-0.3.19.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-if [[ ${PV} = 9999 ]]; then
- EGIT_REPO_URI="https://git.code.sf.net/p/libmwaw/libmwaw"
- inherit autotools git-r3
-else
- SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
- KEYWORDS="amd64 ~arm arm64 ~ppc64 x86"
-fi
-
-DESCRIPTION="Library parsing many pre-OSX MAC text formats"
-HOMEPAGE="https://sourceforge.net/p/libmwaw/wiki/Home/"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-IUSE="doc tools"
-
-BDEPEND="
- sys-devel/libtool
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
-"
-DEPEND="
- dev-libs/librevenge
- sys-libs/zlib
-"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- default
- [[ ${PV} == 9999 ]] && eautoreconf
-}
-
-src_configure() {
- # zip is hard enabled as the zlib is dep on the rdeps anyway
- local myeconfargs=(
- --enable-zip
- --disable-static
- --disable-werror
- $(use_with doc docs)
- $(use_enable tools)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
- find "${D}" -name '*.la' -type f -delete || die
-}
diff --git a/app-text/libmwaw/libmwaw-0.3.20.ebuild b/app-text/libmwaw/libmwaw-0.3.22.ebuild
index f0bf404e1fb2..167928a4dd0b 100644
--- a/app-text/libmwaw/libmwaw-0.3.20.ebuild
+++ b/app-text/libmwaw/libmwaw-0.3.22.ebuild
@@ -1,14 +1,16 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+inherit autotools
+
if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://git.code.sf.net/p/libmwaw/libmwaw"
- inherit autotools git-r3
+ inherit git-r3
else
- SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+ SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tar.xz"
+ KEYWORDS="amd64 ~arm arm64 ~loong ppc64 ~riscv x86"
fi
DESCRIPTION="Library parsing many pre-OSX MAC text formats"
@@ -24,14 +26,16 @@ DEPEND="
"
RDEPEND="${DEPEND}"
BDEPEND="
- sys-devel/libtool
+ dev-build/libtool
virtual/pkgconfig
- doc? ( app-doc/doxygen )
+ doc? ( app-text/doxygen )
"
src_prepare() {
default
- [[ ${PV} == *9999* ]] && eautoreconf
+
+ # Refresh stale libtool, bug #814512
+ eautoreconf
}
src_configure() {
diff --git a/app-text/libmwaw/libmwaw-9999.ebuild b/app-text/libmwaw/libmwaw-9999.ebuild
index f0bf404e1fb2..19e7cff79243 100644
--- a/app-text/libmwaw/libmwaw-9999.ebuild
+++ b/app-text/libmwaw/libmwaw-9999.ebuild
@@ -1,14 +1,16 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+inherit autotools
+
if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://git.code.sf.net/p/libmwaw/libmwaw"
- inherit autotools git-r3
+ inherit git-r3
else
- SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+ SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
fi
DESCRIPTION="Library parsing many pre-OSX MAC text formats"
@@ -24,14 +26,16 @@ DEPEND="
"
RDEPEND="${DEPEND}"
BDEPEND="
- sys-devel/libtool
+ dev-build/libtool
virtual/pkgconfig
- doc? ( app-doc/doxygen )
+ doc? ( app-text/doxygen )
"
src_prepare() {
default
- [[ ${PV} == *9999* ]] && eautoreconf
+
+ # Refresh stale libtool, bug #814512
+ eautoreconf
}
src_configure() {
diff --git a/app-text/libmwaw/metadata.xml b/app-text/libmwaw/metadata.xml
index 09f5b872fd22..f8fefe6463f0 100644
--- a/app-text/libmwaw/metadata.xml
+++ b/app-text/libmwaw/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>office@gentoo.org</email>