summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/libodfgen/libodfgen-9999.ebuild')
-rw-r--r--app-text/libodfgen/libodfgen-9999.ebuild20
1 files changed, 16 insertions, 4 deletions
diff --git a/app-text/libodfgen/libodfgen-9999.ebuild b/app-text/libodfgen/libodfgen-9999.ebuild
index d3f5e575b856..a1e951468328 100644
--- a/app-text/libodfgen/libodfgen-9999.ebuild
+++ b/app-text/libodfgen/libodfgen-9999.ebuild
@@ -1,14 +1,16 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit edo
+
if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://git.code.sf.net/p/libwpd/libodfgen"
inherit autotools git-r3
else
SRC_URI="mirror://sourceforge/libwpd/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+ KEYWORDS="amd64 ~arm arm64 ~loong ~ppc64 ~riscv x86 ~amd64-linux ~x86-linux"
fi
DESCRIPTION="Library to generate ODF documents from libwpd and libwpg"
@@ -16,7 +18,8 @@ HOMEPAGE="http://libwpd.sourceforge.net/"
LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
SLOT="0"
-IUSE="doc"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
RDEPEND="
dev-libs/librevenge
@@ -36,7 +39,16 @@ src_prepare() {
src_configure() {
econf \
--disable-static \
- $(use_with doc docs)
+ $(use_with doc docs) \
+ $(use_enable test)
+}
+
+src_test() {
+ cd test || die
+
+ while read -r test_name ; do
+ edo "${test_name}"
+ done < <(find . -maxdepth 1 -type f -executable || die)
}
src_install() {