summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/libodfgen/libodfgen-9999.ebuild')
-rw-r--r--app-text/libodfgen/libodfgen-9999.ebuild29
1 files changed, 13 insertions, 16 deletions
diff --git a/app-text/libodfgen/libodfgen-9999.ebuild b/app-text/libodfgen/libodfgen-9999.ebuild
index 3e7137661d27..03f14c4c7029 100644
--- a/app-text/libodfgen/libodfgen-9999.ebuild
+++ b/app-text/libodfgen/libodfgen-9999.ebuild
@@ -1,27 +1,26 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-EGIT_REPO_URI="git://git.code.sf.net/p/libwpd/libodfgen"
-[[ ${PV} == 9999 ]] && inherit autotools git-r3
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/libwpd/libodfgen"
+ inherit autotools git-r3
+else
+ SRC_URI="mirror://sourceforge/libwpd/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+fi
DESCRIPTION="Library to generate ODF documents from libwpd and libwpg"
-HOMEPAGE="http://libwpd.sf.net"
-[[ ${PV} == 9999 ]] || SRC_URI="mirror://sourceforge/libwpd/${P}.tar.xz"
-
+HOMEPAGE="http://libwpd.sourceforge.net/"
LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
SLOT="0"
-[[ ${PV} == 9999 ]] || \
-KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
-
IUSE="doc"
-RDEPEND="
- dev-libs/librevenge
-"
-DEPEND="${RDEPEND}
+RDEPEND="dev-libs/librevenge"
+DEPEND="${RDEPEND}"
+BDEPEND="
virtual/pkgconfig
doc? ( app-doc/doxygen )
"
@@ -34,8 +33,6 @@ src_prepare() {
src_configure() {
econf \
--disable-static \
- --disable-werror \
- --with-sharedptr=c++11 \
$(use_with doc docs)
}