summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/libodfgen')
-rw-r--r--app-text/libodfgen/Manifest1
-rw-r--r--app-text/libodfgen/libodfgen-0.1.8.ebuild45
-rw-r--r--app-text/libodfgen/libodfgen-9999.ebuild11
3 files changed, 53 insertions, 4 deletions
diff --git a/app-text/libodfgen/Manifest b/app-text/libodfgen/Manifest
index 4613e27ad6e6..d058078dd507 100644
--- a/app-text/libodfgen/Manifest
+++ b/app-text/libodfgen/Manifest
@@ -1 +1,2 @@
DIST libodfgen-0.1.7.tar.xz 384760 BLAKE2B 93066e52c0651e3714843764f0d023178cf0ddb52c1185f085c70180f4123cd26d79b9ea2c211a82f2681c42c8795c3f062f081161effa7fe821b64b54b82cd8 SHA512 eaf5c6646a9cacf54cb0416b08526f35d18d0618f3f64cf14f4b24537b0285da2786d2f6d6e2c204c8248f900d37287b2c5af79720b0d49452f67b14c86ea36e
+DIST libodfgen-0.1.8.tar.xz 386156 BLAKE2B 8cc55cd6ad39927ca1fec459cb484362877f0eb0a044d806a93ec573ca2d840fece17fdbb58b0b30869af945fe9ddaa23a88729c1802b2b1321d5551f94a32c5 SHA512 e4a15aa7f1db483cdbb9c531bfb234b4794890cc583c70e8aa3374771be8928e7917105d48dab80d1ab6d57e43fa78415097d9b897cb12fb2a609f4647ee99d6
diff --git a/app-text/libodfgen/libodfgen-0.1.8.ebuild b/app-text/libodfgen/libodfgen-0.1.8.ebuild
new file mode 100644
index 000000000000..6c33ab30007c
--- /dev/null
+++ b/app-text/libodfgen/libodfgen-0.1.8.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/libwpd/libodfgen"
+ inherit autotools git-r3
+else
+ SRC_URI="mirror://sourceforge/libwpd/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="Library to generate ODF documents from libwpd and libwpg"
+HOMEPAGE="http://libwpd.sourceforge.net/"
+
+LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND="
+ dev-libs/librevenge
+ dev-libs/libxml2:2
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_with doc docs)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/app-text/libodfgen/libodfgen-9999.ebuild b/app-text/libodfgen/libodfgen-9999.ebuild
index 03f14c4c7029..6c33ab30007c 100644
--- a/app-text/libodfgen/libodfgen-9999.ebuild
+++ b/app-text/libodfgen/libodfgen-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-if [[ ${PV} == 9999 ]]; then
+if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://git.code.sf.net/p/libwpd/libodfgen"
inherit autotools git-r3
else
@@ -13,12 +13,15 @@ fi
DESCRIPTION="Library to generate ODF documents from libwpd and libwpg"
HOMEPAGE="http://libwpd.sourceforge.net/"
+
LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
SLOT="0"
-
IUSE="doc"
-RDEPEND="dev-libs/librevenge"
+RDEPEND="
+ dev-libs/librevenge
+ dev-libs/libxml2:2
+"
DEPEND="${RDEPEND}"
BDEPEND="
virtual/pkgconfig