summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/libwpg/libwpg-0.3.2.ebuild')
-rw-r--r--app-text/libwpg/libwpg-0.3.2.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/app-text/libwpg/libwpg-0.3.2.ebuild b/app-text/libwpg/libwpg-0.3.2.ebuild
deleted file mode 100644
index 1ca82bb199ef..000000000000
--- a/app-text/libwpg/libwpg-0.3.2.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit alternatives
-
-DESCRIPTION="C++ library to read and parse graphics in WPG"
-HOMEPAGE="http://libwpg.sourceforge.net/libwpg.htm"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
-
-LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
-SLOT="0.3"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 x86"
-IUSE="doc static-libs"
-
-RDEPEND="
- app-text/libwpd:0.10[tools]
- dev-libs/librevenge
-"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen )"
-
-src_configure() {
- econf \
- --disable-werror \
- --program-suffix=-${SLOT} \
- $(use_with doc docs) \
- $(use_enable static-libs static)
-}
-
-src_install() {
- default
- find "${D}" -name '*.la' -delete || die
-}
-
-pkg_postinst() {
- alternatives_auto_makesym /usr/bin/wpg2svgbatch.pl "/usr/bin/wpg2svgbatch.pl-[0-9].[0-9]"
- alternatives_auto_makesym /usr/bin/wpg2svg "/usr/bin/wpg2svg-[0-9].[0-9]"
- alternatives_auto_makesym /usr/bin/wpg2raw "/usr/bin/wpg2raw-[0-9].[0-9]"
-}
-
-pkg_postrm() {
- alternatives_auto_makesym /usr/bin/wpg2svgbatch.pl "/usr/bin/wpg2svgbatch.pl-[0-9].[0-9]"
- alternatives_auto_makesym /usr/bin/wpg2svg "/usr/bin/wpg2svg-[0-9].[0-9]"
- alternatives_auto_makesym /usr/bin/wpg2raw "/usr/bin/wpg2raw-[0-9].[0-9]"
-}