summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/lowdown/lowdown-0.8.4-r1.ebuild')
-rw-r--r--app-text/lowdown/lowdown-0.8.4-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-text/lowdown/lowdown-0.8.4-r1.ebuild b/app-text/lowdown/lowdown-0.8.4-r1.ebuild
new file mode 100644
index 000000000000..b517049ebd47
--- /dev/null
+++ b/app-text/lowdown/lowdown-0.8.4-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_PV="VERSION_${PV//./_}"
+DESCRIPTION="Markdown translator producing HTML5, roff documents in the ms and man formats"
+HOMEPAGE="https://kristaps.bsd.lv/lowdown/"
+SRC_URI="https://github.com/kristapsdz/lowdown/archive/refs/tags/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="virtual/libcrypt:="
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/lowdown-0.8.4-configure.patch"
+)
+
+src_configure() {
+ CC="$(tc-getCC)" ./configure || die "./configure failed"
+}
+
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}" AR="$(tc-getAR)" $(usex elibc_musl UTF8_LOCALE=C.UTF-8 '')
+}
+
+src_test() {
+ emake regress
+}