summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/mecab')
-rw-r--r--app-text/mecab/mecab-0.996-r1.ebuild9
-rw-r--r--app-text/mecab/mecab-0.996-r2.ebuild9
2 files changed, 14 insertions, 4 deletions
diff --git a/app-text/mecab/mecab-0.996-r1.ebuild b/app-text/mecab/mecab-0.996-r1.ebuild
index 3e419f7d4581..13064cdcfed4 100644
--- a/app-text/mecab/mecab-0.996-r1.ebuild
+++ b/app-text/mecab/mecab-0.996-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools
+inherit autotools flag-o-matic
DESCRIPTION="Yet Another Part-of-Speech and Morphological Analyzer"
HOMEPAGE="https://taku910.github.io/mecab/"
@@ -44,6 +44,11 @@ src_prepare() {
}
src_configure() {
+ # -Werror=odr -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/924569
+ # https://github.com/taku910/mecab/issues/75
+ filter-lto
+
econf \
$(use_enable static-libs static) \
$(use_with unicode charset UTF-8)
diff --git a/app-text/mecab/mecab-0.996-r2.ebuild b/app-text/mecab/mecab-0.996-r2.ebuild
index 11c5322f3ecf..7ab1b014a7dd 100644
--- a/app-text/mecab/mecab-0.996-r2.ebuild
+++ b/app-text/mecab/mecab-0.996-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools
+inherit autotools flag-o-matic
DESCRIPTION="Yet Another Part-of-Speech and Morphological Analyzer"
HOMEPAGE="https://taku910.github.io/mecab/"
@@ -45,6 +45,11 @@ src_prepare() {
}
src_configure() {
+ # -Werror=odr -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/924569
+ # https://github.com/taku910/mecab/issues/75
+ filter-lto
+
econf \
$(use_enable static-libs static) \
$(use_with unicode charset UTF-8)