summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/multitail/files/multitail-6.3-as-needed.patch')
-rw-r--r--app-text/multitail/files/multitail-6.3-as-needed.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-text/multitail/files/multitail-6.3-as-needed.patch b/app-text/multitail/files/multitail-6.3-as-needed.patch
new file mode 100644
index 000000000000..27b2cfaf1659
--- /dev/null
+++ b/app-text/multitail/files/multitail-6.3-as-needed.patch
@@ -0,0 +1,31 @@
+--- a/Makefile
++++ b/Makefile
+@@ -8,11 +8,11 @@ CONFIG_FILE=$(DESTDIR)/etc/multitail.conf
+ CC?=gcc
+ DEBUG=-g -O2 -Wall # -D_DEBUG # -pg # -D_DEBUG #-pg -W -pedantic # -pg #-fprofile-arcs
+ ifeq ($(UTF8_SUPPORT),yes)
+-LDFLAGS+=-lpanelw -lncursesw -lutil -lm
+-CFLAGS+=-funsigned-char -D`uname` -DVERSION=\"$(VERSION)\" -DCONFIG_FILE=\"$(CONFIG_FILE)\" -DUTF8_SUPPORT -D_FORTIFY_SOURCE=2
++LIBS+=`$(PKG_CONFIG) --libs ncursesw panelw` -lutil -lm
++CFLAGS+=-funsigned-char -D`uname` -DVERSION=\"$(VERSION)\" $(DEBUG) -DCONFIG_FILE=\"$(CONFIG_FILE)\" -DUTF8_SUPPORT
+ else
+-LDFLAGS+=-lpanel -lncurses -lutil -lm
+-CFLAGS+=-funsigned-char -D`uname` -DVERSION=\"$(VERSION)\" -DCONFIG_FILE=\"$(CONFIG_FILE)\" -D_FORTIFY_SOURCE=2
++LIBS+=`$(PKG_CONFIG) --libs ncurses panel` -lutil -lm
++CFLAGS+=-funsigned-char -D`uname` -DVERSION=\"$(VERSION)\" $(DEBUG) -DCONFIG_FILE=\"$(CONFIG_FILE)\"
+ endif
+
+ OBJS=utils.o mt.o error.o my_pty.o term.o scrollback.o help.o mem.o cv.o selbox.o stripstring.o color.o misc.o ui.o exec.o diff.o config.o cmdline.o globals.o history.o xclip.o
+@@ -20,10 +20,10 @@ OBJS=utils.o mt.o error.o my_pty.o term.o scrollback.o help.o mem.o cv.o selbox.
+ all: multitail
+
+ multitail: $(OBJS)
+- $(CC) $(OBJS) $(LDFLAGS) -o multitail
++ $(CC) $(CFLAGS) $(LDFLAGS) -Wall -W $(OBJS) -o $@ $(LIBS)
+
+ multitail_ccmalloc: $(OBJS)
+- ccmalloc --no-wrapper $(CC) -Wall -W $(OBJS) $(LDFLAGS) -o ccmultitail
++ ccmalloc --no-wrapper $(CC) $(CFLAGS) $(LDFLAGS) -Wall -W $(OBJS) -o $@ $(LIBS)
+
+ install: multitail
+ mkdir -p $(DESTDIR)$(PREFIX)/bin